mLastFloaterY doesn't enforce that float can't be above earlier float

RESOLVED FIXED in mozilla1.4alpha

Status

()

Core
Layout: Floats
P1
major
RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

Trunk
mozilla1.4alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch])

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

14 years ago
nsBlockReflowState::mLastFloaterY isn't sufficient to enforce that a float can't
be above an earlier float.  I'll attach a testcase to show this.  It needs to be
on the space manager.
(Assignee)

Comment 1

14 years ago
Created attachment 116872 [details]
testcase
(Assignee)

Comment 2

14 years ago
Created attachment 116876 [details] [diff] [review]
patch

This fixes this bug and bug 177331.
(Assignee)

Updated

14 years ago
Blocks: 177331
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.4alpha
(Assignee)

Updated

14 years ago
Whiteboard: [patch]
(Assignee)

Updated

14 years ago
Attachment #116876 - Flags: superreview?(roc+moz)
Attachment #116876 - Flags: review?(roc+moz)
(Assignee)

Comment 3

14 years ago
Note that this patch also includes the patch for bug 115153, simply because I
haven't checked it in yet.
Comment on attachment 116876 [details] [diff] [review]
patch

I dislike #if 0. Is there a good reason to leave this in?
Attachment #116876 - Flags: superreview?(roc+moz)
Attachment #116876 - Flags: superreview+
Attachment #116876 - Flags: review?(roc+moz)
Attachment #116876 - Flags: review+
(Assignee)

Comment 5

14 years ago
I'm not really sure.  nsSpaceManager was originally written to be rather
general, and I've already polluted it with a good bit of
block-specific/float-specific stuff, but I think it really needs to go more in
that direction (see bug 191448) and, furthermore, that we're unlikely to need
the code for anything other than floats.  So I guess I'm inclined to just remove
it if you like that idea as well.  (cc:ing kin if he wants to chime in as well.)
I can't think of anything that we're going to need "space management" for beyond
floats, at least for the forseeable future. (I can imagine at some point we
might want support for positioned elements that siblings flow around, but you
can't even do that in CSS3 ... right?)

Even if we could forsee a potential broader use, it's probably better to get
floats working well and then figure out how to extend the code later.
(Assignee)

Comment 7

14 years ago
Created attachment 116883 [details] [diff] [review]
patch with removal instead of #if 0
Attachment #116876 - Attachment is obsolete: true
Attachment #116883 - Flags: superreview+
Attachment #116883 - Flags: review+
(Assignee)

Comment 8

14 years ago
Ran the regression tests.  Saw only noise.  Will add attachment 116872 [details] to the
block/bugs regression tests.
(Assignee)

Comment 9

14 years ago
Fix checked in to trunk, 2003-03-11 15:56 PST.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.