Identify and remove all remaining traces of copyright artwork.

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Jason Bassford, Assigned: asa)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: * Do not debate the artwork here. *)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030306
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030306

I'm opening this to get a handle on the various Mozilla components that still
need to have artwork removed, particularly since I haven't seen bugs filed on
some components for which they should have been filed.

So far, the splash screen has been updated via bug 194291.  Bug 194930 is
working on updating the artwork for the installer.

However, there are still several other areas that include the old questionable
artwork which, as I understand it, comprise both the green and red lizards:

1. about:logo
2. icons
3. throbber

These are just the areas that have come up so far in a MozillaZine discussion:

http://www.mozillazine.org/forums/viewtopic.php?t=7181

Another question that was raised was whether or not the Revolution font has
copyright issues (see bug 194291 comment 67) - nobody replied to that one.
(Hopefully not, otherwise existing invidual bugs would have to be reopened.)

Also, of course, there is the Mozilla.org Web site itself (which should also be
updated), but this particular bug is only about the browser elements.

I wasn't sure if this should be made into a tracking bug or not - since I don't
believe that all of the individual bugs that would finally resolve this issue
have yet been created.  (Can you have a tracking bug that remains open even when
all of its dependencies have been resolved - since you know that the problem its
tracking is still not resolved?)

Lastly, please DO NOT comment here about whether or not you like the artwork. 
That's irrelevant to this bug.

Reproducible: Always

Steps to Reproduce:
Look at all of the various screens in Mozilla.
Actual Results:  
Old copyright artwork remains.

Expected Results:  
All copyright artwork should be gone.
(Reporter)

Comment 1

15 years ago
Setting dependencies to copyright artwork bugs I know about - even the one
that's now closed in case the Revolution font issue isn't an idle question.
Depends on: 194291, 194930
Whiteboard: * Do not debate the artwork here. *

Comment 2

15 years ago
Jason: opening Mail&News for 1st time show old good Mozilla (green lizzard).
(Reporter)

Comment 3

15 years ago
I don't have the time right now to file individual bugs for specific elements /
components not already addressed (although I will get to that tomorrow) but feel
free to file any you wish yourself and mark the appropriate dependencies back to
this bug.
(Reporter)

Comment 4

15 years ago
CCing Jason, since it's his artwork.

Comment 5

15 years ago
The mailnews image in question is:

http://www.mozilla.org/mailnews/mail_mozilla.gif

Comment 6

15 years ago
Bug 28028 is the fundamental bug dealing with image rights. That should probably
be a dependency of this bug, since if bug 28028 comment 25 is to be believed,
the fundamental problem with images in the tree is the desire of mozilla.org to
retain  the rights to those images.
(Reporter)

Updated

15 years ago
Depends on: 28028
(Reporter)

Comment 7

15 years ago
Although, I don't see why the resolution of bug 28028 in terms of *imagery*
should effect this bug which is all about removing imagery.  (If some imagery is
resolve positively, does that mean that logos and everything are going back in
again?)  However, if it has any bearing on the copyright/legal status of the
Revolution font used, then it could have bearing on whether or not that should
be pulled/changed also...

Comment 8

15 years ago
Re: Comment #1: "in case the Revolution font issue isn't an idle question."

Using the font itself isn't a question. I contacted the foundry, T26.com:

> From: jesus_x@mozillanews.org (Grey Hodge)
> Date: Tue, 11 Mar 2003 16:34:43 -0600
> To: info@t26.com, david@segura-inc.com
> Subject: Font licenses
> 
> Specifically, my question is to the use-terms, not the number of
> copies. An example is House Industries royalty rates. As described here:
> http://houseind.com/house.php?page=licensing&subpage=explanation#2
> you can't use their fonts without royalties in the following uses:
> 
> 1. PRODUCT FOR SALE
> 2. LOGO DESIGN
> 3. RETAIL PACKAGING/POINT OF SALE DISPLAY
> 4. APPLICATIONS OVER 500,000 IMPRESSIONS
> 
> Which, in some scopes, is pretty darn limiting, when you really think of how
> broad those applications are. It essentially prohibits almost any retail
> use. The Internet restrictions are even worse:
> 
> "Web use is unrestricted in applications under 150 x 150 pixels.
> Applications over this size will be priced on an individual basis."
> 
> This makes their fonts almos worthless for Internet use for anyone who isn't
> a decent size corporation.
> 
> So my question is, what are your terms here? I'm not talking IBM redoing
> their logo in a $20 font purchased from you, but what about Web site
> specific graphics, free/open source software logos, etc.? Non-commercial,
> but high-profile projects.
> 
> I thank you for your reply.

And their reply:

-----
From: Silas Dilworth <silas@t26.com>
Date: Tue, 11 Mar 2003 17:43:58 -0600
To: <jesus_x@mozillanews.org>
CC: Chris Burque <chris@t26.com>

Grey:

We don't limit your use of alphanumeric fonts.  You may use them however you
need.  We do reserve separate negotiable terms for dingbat fonts, but if
that's not what you're asking about, then you're licensed to use our fonts
till you wear them out!

Thanks for the inquiry.

******************************
Silas Dilworth / silas@t26.com
T-26 Font Technician

[T-26] DIGITAL TYPE FOUNDRY
1110 North Milwaukee Avenue
Chicago, Illinois  60622  USA
773.862.1201   f:773.862.1214
1-888-T26-FONT    www.t26.com
******************************
-----

Since Revolution is alphanumeric, we're clear to use it without restriction, as
long as the purchase requirements have been met. I'd assume Netscape went ahead
and spent the $19 for the font back in 1998, if not, I'm sure someone can
scrounge up $19 to donate to buy a license.

As for the issues around the idea of a trademark/wordmark/logo of "mozilla"
and/or "mozilla.org" in that font, that's separate from the issue of being
allowed to use the font itself.
(Reporter)

Updated

15 years ago
Depends on: 196978
(Reporter)

Updated

15 years ago
Depends on: 196980, 196982, 196984
Product: Browser → Seamonkey
(Reporter)

Comment 9

13 years ago
Mozilla 1.7 branch will not be modified, and this isn't applicable to SeaMonkey
at this point.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.