each identical icon on a page gets retrieved

VERIFIED WORKSFORME

Status

()

Core
Networking: HTTP
--
minor
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Wenzhuo Zhang, Assigned: Darin Fisher)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030310
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030310

I am experiencing much slower speed when opening pages full of identical icons,
e.g. the mozillazine forum, and apache ftp listings, etc. Those icons display
one after one, instead of all at once. urlsnarf shows that each identical links
gets retrieved:

...
172.16.10.27 - - [12/Mar/2003:10:12:41 +0800] "GET
http://www.mozillazine.org/forums/templates/subSilver/images/folder.gif
HTTP/1.1" - - "http://www.mozillazine.org/forums/viewforum.php?f=3" "Mozilla/5.0
(X11; U; Linux i686; en-US; rv:1.3) Gecko/20030310"
172.16.10.27 - - [12/Mar/2003:10:12:41 +0800] "GET
http://www.mozillazine.org/forums/templates/subSilver/images/icon_latest_reply.gif
HTTP/1.1" - - "http://www.mozillazine.org/forums/viewforum.php?f=3" "Mozilla/5.0
(X11; U; Linux i686; en-US; rv:1.3) Gecko/20030310"
172.16.10.27 - - [12/Mar/2003:10:12:41 +0800] "GET
http://www.mozillazine.org/forums/templates/subSilver/images/folder.gif
HTTP/1.1" - - "http://www.mozillazine.org/forums/viewforum.php?f=3" "Mozilla/5.0
(X11; U; Linux i686; en-US; rv:1.3) Gecko/20030310"
172.16.10.27 - - [12/Mar/2003:10:12:41 +0800] "GET
http://www.mozillazine.org/forums/templates/subSilver/images/icon_latest_reply.gif
HTTP/1.1" - - "http://www.mozillazine.org/forums/viewforum.php?f=3" "Mozilla/5.0
(X11; U; Linux i686; en-US; rv:1.3) Gecko/20030310"
...

Reproducible: Always

Steps to Reproduce:
1. Opening a page full of identical icons
2.
3.

Actual Results:  
Identical icons get retrieved and displayed one after the other.

Expected Results:  
Retrieve identical icons once, and display them all at once.

The problem appears somewhere between 1.3b and 1.3RCs.
-> Networking:http ?
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
Keywords: regression
QA Contact: asa → httpqa
(Reporter)

Comment 2

15 years ago
Well, I just tried it in mozilla-1.0.1. It retrieves and displays identical
icons one after another too.

So, what I said in the bug report "The problem appears somewhere between 1.3b
and 1.3RCs." is wrong. I guess it's because the release of 1.3b coincides with
the Internet slowdown caused by the MS SQL slammer worm.
(Assignee)

Comment 3

15 years ago
with linux trunk build 2003030905, this is the list of URLs i see being loaded
from the supplied mozillazine link:

/forums/viewforum.php?f=3
/forums/templates/subSilver/style.css
/image/new/title.gif
/image/new/blimp.gif
/forums/templates/subSilver/images/lang_english/post.gif
/forums/templates/subSilver/images/folder_announce.gif
/forums/templates/subSilver/images/icon_latest_reply.gif
/images/x-click-but04.gif
/forums/templates/subSilver/images/folder.gif
/forums/templates/subSilver/images/icon_minipost.gif
/forums/templates/subSilver/images/folder_new.gif
/forums/templates/subSilver/images/folder_new_hot.gif
/forums/templates/subSilver/images/folder_hot.gif
/forums/templates/subSilver/images/folder_sticky.gif
/forums/templates/subSilver/images/folder_lock_new.gif
/forums/templates/subSilver/images/folder_lock.gif
/image/navHeader.gif
/image/newsearch.gif
/image/new/tile_new.png

none of the image requests are repeated.

Wenzhuo: have you modified any preferences under Advanced->Cache or Networking
HTTP?  are you using a proxy server?
Severity: normal → minor
(Reporter)

Comment 4

15 years ago
I just tried to reproduce the problem using a brand new profile, but failed.
Neither 1.3rc or 1.0.1 (redhat build) exhibits the problem on a new profile.

I remember the profile that caused the problem was created after 1.2.1. I did
not change anything w.r.t. caching/http/proxy, and I do not have proxy on my
network, although my ISP might do transparent proxy. I guess one of the previous
builds I had used screwed up the profile.

I'll remember to reproduce problems on a fresh profile first before filing bugs
later. Thanks.

Darin: what preferences might be causing this? All the cache/http/proxy settings
of my problematic profile have default values.
(Reporter)

Comment 5

15 years ago
Created attachment 116945 [details]
HTTP requests when using the bad profile.

http requests when opening http://www.mozillazine.org/forums/viewforum.php?f=3
(using the corrupted profile).

Comment 6

15 years ago
Resolving WORKSFORME as per reporter's comments. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

15 years ago
Wenzhuo: thanks for the additional information.  i'm really not sure what went
wrong with your old profile, but if you like you can privately email me a copy
of your prefs.js file, and then i'll take a look to see if anything might
explain this.  thanks!
(Reporter)

Comment 8

15 years ago
This is the first and the only relevant (I think) hunk of the diff between the
old prefs.js and new prefs.js:

$ diff prefs.js.bad prefs.js.good 
4,10c4,5
< user_pref("browser.cache.disk.enable", false);
< user_pref("browser.cache.disk.parent_directory",
"/home/wenzhuo/.mozilla/default/rgnfc3ih.slt");
< user_pref("browser.cache.memory.enable", false);
< user_pref("browser.dom.window.dump.enabled", false);
< user_pref("browser.download.dir", "/home/wenzhuo");
< user_pref("browser.history.last_page_visited",
"http://www.mozillazine.org/forums/viewforum.php?f=3&sid=543334c8d188f55ad320bc3b1345a66a");
< user_pref("browser.search.defaultengine",
"engine:///home/wenzhuo/mozilla/searchplugins/NetscapeSearch.src");
---
> user_pref("browser.cache.disk.parent_directory",
"/home/wenzhuo/.mozilla/default/cgqbe561.slt");
> user_pref("browser.search.defaultengine",
"engine:///home/wenzhuo/mozilla-1.3/searchplugins/google.src");
14,57d8
...

I don't know what changed "browser.cache.disk.enable" and
"browser.cache.memory.enable" to false. I didn't do it myself and the Cache pane
of the Preferences dialogue does not show as such.
(Assignee)

Comment 9

15 years ago
< user_pref("browser.cache.disk.enable", false);
< user_pref("browser.cache.memory.enable", false);

Wenzhuo: yeah, not having a cache is definitely what caused the problem.  not
sure what could have caused those entries to appear in your prefs.js file.  i
don't even think the UI is capable of setting those prefs to false.  it only
affects the size of the cache.  wierd.

v.
Status: RESOLVED → VERIFIED

Comment 10

15 years ago
The Cache Service only 'gets' these prefs.  It never sets them.  How the prefs
got set continues to be a mystery.
You need to log in before you can comment on or make changes to this bug.