custom headers cause addition of bare linefeeds

RESOLVED DUPLICATE of bug 195965

Status

RESOLVED DUPLICATE of bug 195965
16 years ago
11 years ago

People

(Reporter: samjie, Assigned: bugzilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.2.1) Gecko/20021130

While trying to submit a bug to the Debian BTS with the X-Debbugs-CC: custom
header, qmail's smtp server complained, sending me to the url above. I have
modified prefs.js by hand, as follows:

user_pref("mail.compose.other.header", "X-Debbugs-CC,X-Message-Flag");

I suspect this is a trivial problem with the patches introduced some time ago
for custom headers.

Reproducible: Always

Steps to Reproduce:
1. Add a custom header (mail.compose.other.header in prefs.js)
2. Compose a mail and use the custom header
3. Observe bare line feed in mail as sent to smtp server

Actual Results:  
qmail complained about bare linefeeds

Expected Results:  
crlf should have been used as per rfcs

Comment 1

16 years ago
this was fixed

*** This bug has been marked as a duplicate of 195965 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.