Pop-up blocking: Window-spanning plugin objects (flash, video...) intercept right clicks

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: andre, Assigned: shliang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Note:
I have divided this bug into two parts because the problem mentioned later will
arise as soon as (only) the first part of this bug gets fixed. But the first
part will be easier (=>faster) to implement and that is more important.


Problem:
The new popup-"service" using flash popups that span the whole popupped window
enables plugins (flash, video,...) to intercept all right-clicks and thus users
cannot click "Reject pop-ups from this site" anymore.

Solution:
Add a context menu icon to the status bar (which acts as if you had right
clicked into the window).


Extension:
Use pop-ups with frames using objects spanning the whole frames.
=> If there are more frames, which one should this context menu reference to?

Solution:
Pop-up frame selector.
to shliang
Assignee: blaker → shliang

Comment 2

16 years ago
*** Bug 208753 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
Mozilla now uses whitelist instead of black list, so this is worksforme
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.