Right click on a link menus in different order between 1.0.2 and 1.3

RESOLVED DUPLICATE of bug 159278

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 159278
15 years ago
4 years ago

People

(Reporter: Scott Kitterman, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021216
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

I tend to right click and open links in a new tab a lot.  Because the menus are
not in the same sequence between 1.0.2 and 1.3b, I find it disconcerting when I
switch back and forth between the two on different computers.  I often end up
opening a new window by mistake.  In theory I could slow down and read the menu
each time before I click, but that just isn't the way proficient users deal with
a system.

Reproducible: Always

Steps to Reproduce:
1.  Go to any web page with a link
2.  Right click on the link
3.  If in 1.0.2, menu will have Open Link in New Tab first and Open Link in New
Window second
4.  If in 1.3b, menu will have Open Link in New Window first and Open Link in
New Tab second

Actual Results:  
It is very confusing when switching back and for between machines with 1.0.2 and
1.3 on them.  Just as I get habituated to click on the top of the menu, I'm on
the other machine and I have to adjust to clicking on the second from the top of
the menu.

Expected Results:  
User interface should be consistent across versions to the extent feasible given
the different feature sets.

Recommend this be fixed on the unstable branch (1.4).  Consistency in user
interface will make it easier for people like me who have some computers on
which stability is paramount, but who still want to run leading edge where we
can to help out with testing.
First, this is the wrong component (this component is for bugs in the actual
menu implementation).

Second, this is a duplicate.  And this behavior is _not_ likely to change.
Assignee: hyatt → asa
Component: XP Toolkit/Widgets: Menus → Browser-General
QA Contact: shrir → asa
Whiteboard: DUPEME
(Reporter)

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 159278 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Bug 159278 should have (IMO) been wontfixed. This bug should be an RFE to back
it out.
Product: Browser → Seamonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.