Page with PNG images corrupts window rendering / painting

RESOLVED EXPIRED

Status

Core Graveyard
GFX
--
major
RESOLVED EXPIRED
15 years ago
9 years ago

People

(Reporter: Steve Krulewitz, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030304 Phoenix/0.5
Build Identifier: 

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030310

Going to the URL http://shr.aaas.org/hrdag/product/analyzer/screens.html causes
something to go very wrong with the window rendering / painting.  The entire
window (including browser chrome) seems to stop repainting itself, which causes
a smearing of all the graphics contained within the browser window.  Once this
page is in the browser, the problem seems to spread to other mozilla based browsers.


Reproducible: Always

Steps to Reproduce:
1. Go to http://shr.aaas.org/hrdag/product/analyzer/screens.html
2. Scroll around or move browser window off the edge of the screen and back again


Actual Results:  
Messed up diplsay

Expected Results:  
Not mess up =P

I've seen this problem happen every now and then, and I've finally found a URL
that it happens all the time with.  I will attach my attempt at isolating the
problem by removing all the extra html and images from the page until the
problem stops occurring.  However, it seemed as I removed the large PNG images,
the problem progressively went away until I could not reproduce it.  The
attached HTML page is a page that still exhibits the problem, however, if you
remove one more PNG image from the page the problem will go away.

Another strange thing is that if I have another mozilla based browser open --
say Phoenix -- as soon as I go to the URL with Mozilla, the Phoenix display is
corrupted as well.

My video card is an ATI Rage Pro Turbo AGP 2X with the following details:
ASIC Type:       3D RAGE PRO
ASIC ID:         4742
Bus Type:        AGP 1X, AGP 2X
BIOS Version:    3.086
BIOS Part        Number: 113-49801-101
BIOS Date:       1998/05/25
Memory Size:     8.0M
Memory Type:     SDRAM
Driver File:     Ati2drad.dll
Release Version: J5.21.0 B18
(Reporter)

Comment 1

15 years ago
Created attachment 116980 [details]
minimal testcase
(Reporter)

Comment 2

15 years ago
Created attachment 116981 [details]
very strange screenshot

I tried to take a screenshot of the problem, but got some strange results. 
While a browser window was showing the problem, I tried using SnagIt and it
refused to work.  Then I tried to load Photoshop, and it crashed while loading.
 If I did a ctrl-printscreen, then quit Mozilla, then loaded Photoshop and
pasted the screenshot, it worked -- but I got this strange black and white
thing.	So I pasted the screenshot into mspaint and got the same thing.  This
is the attachment.

Comment 3

15 years ago
I cannot reproduce this with either the testcase or URL supplied (mozilla 1.3,
windows XP pro SP1, 512Mb, ATI mobility M3 8Mb). This means that either I did
something wrong (quite likely), or this bug was introduced after mozilla 1.3.

Another thing that might be the cause is the ATI rage pro. I had one of these
cards, and it never worked right with mozilla. It would corrupt images when the
page was scrolled, and draw black boxes instead of widgets. ATI, of course, do
not support the card, and refuse to make drivers for it that actually work.

Can you reproduce the problem with a different graphics card?
(Reporter)

Comment 4

15 years ago
With the latest nightly, I can't reproduce this on my laptop (non-ati) or my
desktop anymore (had the ati, now has a voodoo5).  I wouldn't hesitate to blame
the ATI drivers as their drivers have always seemed to have problems.

Mark invalid?

Comment 5

15 years ago
Have a look at a bug, which also describes interaction of open Gecko Browsers.

Bug 206225 Window canvas of Gecko apps doesn't refresh when *MANY* pictures are
shown.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.