If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Search Ahead Find (Find While You Type) intermittently switches to matching individual characters in URLs

VERIFIED DUPLICATE of bug 190555

Status

SeaMonkey
Find In Page
VERIFIED DUPLICATE of bug 190555
15 years ago
9 years ago

People

(Reporter: Chris, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

I think that the search ahead find feature for searching URLs in pages is
excellent. But I have found, especially with this 1.3 beta that it sometimes
seems to switch modes and find individual characters. If I type at a moderate
speed something like the words 'moderate' over a page that has all the words in
this description in it it will land first on 'sometimes', then 'to' then 'modes'
then 'modes' again with just the 'e' highlighted, etc.. In other words it seems
to switch from constructing larger and larger search strings as I add characters
to simply searching for the next occurance of each character as I type.

I haven't found any commonality about pages or situations in which this occurs.
Most disturbingly it seems to come and go. For a few minutes it will work fine,
then switch to the error mode I described above for a few minutes, then switch
back. I'm probably doings something (closing tabbed windows, switching from
pages containing frames to pages not containing frames, etc..) that is causing
this to happen or not happen, but I haven't yet worked out the pattern. 

I am suprised that this hasn't been reported before.

Reproducible: Sometimes

Steps to Reproduce:
see details
Actual Results:  
see details

Expected Results:  
see details
(Assignee)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 190555 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
excellent! Thanks!
vfry'ing as dup.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.