Using mozilla vice window manager in a vnc logon, can not type in text-boxes, but mouse works.

RESOLVED DUPLICATE of bug 78928

Status

()

Core
Event Handling
--
major
RESOLVED DUPLICATE of bug 78928
15 years ago
15 years ago

People

(Reporter: Douglas Muhlbauer, Assigned: saari (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

When I user mozilla without a window manager, I am unable to type in any text
area (URL box, text boxes etc).  I first found the problem when I changed my
$HOME/.vnc/xstartup to read "exec /usr/local/mozilla/mozilla &"  When I started
my vncserver and logged in, mozilla had started and the mouse worked but no
keyboard.  I then attempted to change my default shell to mozilla by changing
the /etc/passwd file like this
"mylogin:x:500:500::/home/mylogin:/usr/local/mozilla/mozilla".  Same result,
logged in, started mozilla, mouse=good, keyboard=bad.

I've tested the same set up in netscape communicator 4.79 and it worked fine.
 


Reproducible: Always

Steps to Reproduce:
1.edit /etc/passwd and change the 7th field in your login's entry to read
  /usr/local/mozilla/mozilla
  (Or where ever your startup script is located)
2.logoff
3.login and try to type in the browser

Actual Results:  
I was unable to type in any text area in the browser

Expected Results:  
allowed me to type in the text areas
(Reporter)

Comment 1

15 years ago
I tested the same setup with the galeon 1.2.0 browser and it worked.  Seems that
mozilla is the only browser I have installed that doesn't work as the default shell.

*** This bug has been marked as a duplicate of 78928 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.