If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Keychain doesn't work on this web page

RESOLVED WONTFIX

Status

Camino Graveyard
General
RESOLVED WONTFIX
15 years ago
14 years ago

People

(Reporter: Dia Fora, Assigned: saari (gone))

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7

In the above mentioned page as well in the
https://secure.ingdirect.ca/InitialINGDirect.html?command=displayLogin&device=web&locale=en_CA
page the stored password does not get filled. The field remain empty.

Keychain works on other sites properly. Deleting the keychain prefs, or the
entries for these sites doesn't help. Creating a new keychain doesn't fix the
problem either.

Keychain used to work with Chimera, but stoped working at Camino 0.7. I have
used two of the nightly builds but don't solve the problem.

Reproducible: Always

Steps to Reproduce:
1.Go to the URL
2.Wait for the page to load and for the fields to be field.
3.Keep waiting.
Actual Results:  
Nothing. Keychain doesn't even prompt me for access.

Expected Results:  
Fill the fields with the card number and the password.

Comment 1

15 years ago
I'm seeing the same behavior on Camino 0.7 at my bank's web site:

https://www4.usbank.com/internetBanking/RequestRouter?requestCmdId=DisplayLoginPage

Camino won't save to the keychain or read from the keychain for this site.

I've tried the latest nightly build (today is 3/28/03) and it still doesn't
work. This was never a problem up through Chimera 0.6. I even downloaded and
reinstalled Chimera 0.6 to confirm that it's not a problem there. This seems to
be specific to Camino 0.7 and continues in the more recent nightlies.

You should be able to test this by visiting the above page, entering a bogus
username and password, and seeing if it prompts you to save to the keychain. It
doesn't.

Comment 2

15 years ago
John, remember that Mozilla (and Camino) offer sites the ability to block the
Password Manager and Keychain from storing passwords if they desire, and many
institutions (such as banks) take advantage of this feature. (In fact, they
insist on it to support Mozilla and Camino.)

Comment 3

15 years ago
Greg,

Is this 'blockability' new to Camino 0.7? It doesn't happen in Chimera 0.6.
Thus, unless the ability for a website to block the Password Manager/Keychain is
new in Camino, and didn't previously exist in Chimera, then it looks like this
is a bug that was intorduced with 0.7. In other words, if US Bank is blocking
the keychain, why isn't it blocked in in Chimera? Is it an annoying new feature,
or is it a bug?

Thanks for your time,

John

Updated

15 years ago

Comment 4

15 years ago
No, John, it's not new to 0.7.

Comment 5

15 years ago
In that case there's a problem with 0.7 because I'm currently using 0.6 to
access US Bank, and keychain integration works fine.

Comment 6

15 years ago
Similar: bug 178561 and bug 181206. In both cases, it sounds like form
submission JavaScript may be to blame.
page has "autocomplete=no" on it, this is not a bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.