Ability to edit serverlist for a network

RESOLVED DUPLICATE of bug 27807

Status

Other Applications
ChatZilla
--
major
RESOLVED DUPLICATE of bug 27807
15 years ago
14 years ago

People

(Reporter: Max Alekseyev, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Chatzilla 0.8.23 [Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.4a) Gecko/20030311]

CharZilla generously offers: "Available networks are [dalnet, efnet, freenode,
hybridnet, moznet, quakenet, slashnet, undernet, webbnet]."
But there is no way to edit a serverlist for some network. 

Say, most servers associated with efnet by default are unaccessible from here.
In opposite, there are several servers with reliable connection that are missed
in ChatZilla efnet's serverlist. How can I edit the serverlist?
(Reporter)

Comment 1

15 years ago
To illustrate the problem, this is a typical log of attemp to connect efnet:

[INFO]	Connecting to efnet via irc.mcs.net:6667, attempt 1 of 5...
[ERROR]	Unknown host irc.mcs.net.
[INFO]	Connecting to efnet via irc.prison.net:6667, attempt 2 of 5...
[ERROR]	Connection to efnet (irc.prison.net:6667) timed out.
[INFO]	Connecting to efnet via irc.freei.net:6667, attempt 3 of 5...
[ERROR]	Unknown host irc.freei.net.
[INFO]	Connecting to efnet via irc.magic.ca:6667, attempt 4 of 5...
[ERROR]	Connection to efnet (irc.magic.ca:6667) timed out.
[INFO]	Connecting to efnet via irc.mcs.net:6667, attempt 5 of 5...
[ERROR]	Unknown host irc.mcs.net.
[ERROR]	Connection attempts exhausted, giving up.

On the other hand, the servers irc.isprime.com, irc.rt.ru and some others works
great. So I would like to renew completely a serverlist for efnet.
(Reporter)

Updated

15 years ago
Blocks: 197159
(Assignee)

Comment 2

15 years ago
you can modify the server list with a startup script.  see the example at
http://www.hacksrus.com/~ginda/chatzilla/chatzillarc.js.
(Reporter)

Comment 3

15 years ago
That's fine as a temporary solution.
But I vote for UI preference page maintaining networks/servers settings.

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 27807 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.