Nested <div> elements used with CSS for positioning are not visible.

RESOLVED INVALID

Status

()

Core
Layout: View Rendering
--
major
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Doug Sauer, Assigned: roc)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Text and images positioned on the page within nested "div" elements are not
visible.  Other "div" elements that are not nested display as expected. This
page and associated stylesheets validate at w3.org for HTML and CSS.  Mozilla
versions 1.2.1 and before display as expected.  This may be seen at related URL
and I will attach a .ZIP file with source for local use.

Reproducible: Always

Steps to Reproduce:
1. View page in question


Actual Results:  
Empty area where nested 'div' elements should display.

Expected Results:  
Background image, image, and several text lists should display.
(Reporter)

Comment 1

15 years ago
Created attachment 117051 [details]
Source files demonstrating problem.
(Reporter)

Comment 2

15 years ago
Created attachment 117052 [details]
Expected display

Screen shot of Netscape 7.0.2 displaying page as expected.
(Reporter)

Comment 3

15 years ago
Created attachment 117053 [details]
Mozilla 1.3 display

Screen shot of unexpected display in Mozilla 1.3
Looks like bug 79315 to me (the content in question is overflowing a rel. pos. div)
Depends on: 79315

Comment 5

15 years ago
This bug (which I haven't confirmed) must be a recent regression, because the 
URL works for me in Moz 1.2.1, and Doug says it works for him in Netscape 7. 
Therefore, Boris, I don't think it would be directly related to bug 79315, 
which has existed for ages. However, perhaps it might be related to the fix for 
bug 66147, for which a patch has been checked in since 1.2.1.

Comment 6

15 years ago
Doug, it would really help if you could devise and post a simplified test case.
(Reporter)

Comment 7

15 years ago
Created attachment 117297 [details]
Simple HTML w/embedded CSS demonstrating problem.

This is a simplified test case (if I understand your request).	That is, it is
a small document with embedded styles and just enough HTML to demonstrate the
problem.  This document validates for HTML and CSS at w3.org.  I will attach
two screen shots of the test case document displayed in Mozilla 1.2.1
(correctly) and Mozilla 1.3 (incorrectly).
(Reporter)

Comment 8

15 years ago
Created attachment 117298 [details]
Screen shot of test case in Mozilla 1.2.1

Simplified test case displaying as expected in Mozilla 1.2.1.  It displays
similarly in Netscape 7.02 and IE 5.5/Win.
(Reporter)

Comment 9

15 years ago
Created attachment 117299 [details]
Test case in Mozilla 1.3

Demonstrating problem.
This is invalid.  The outer div has an explicit "overflow:hidden" set on it and
its only child has no in-flow children (they are all floated), so the height of
the whole thing is 0 and the floats are overflowing it.  Hence they are not
shown, which is correct.

Further, the background is set on the div that becomes 0 height, so it does not
show either.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.