Phoenix should always handle image files, not download

VERIFIED DUPLICATE of bug 183653

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 183653
15 years ago
10 years ago

People

(Reporter: Hunter Clarke, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030312 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030312 Phoenix/0.5

When clicking the link to an attached .jpg image on this vBulletin system, which
uses a PHP redirect to the image, Phoenix prompts to open or save the file every
time. Also, it  will not save a default action to use on the object even if the
"Always show this dialog before handling files of this type" box is checked.

Reproducible: Always

Steps to Reproduce:
1. Go to the link listed (will need to register as a board user)
2. click the attachment link


Actual Results:  
Described behavior.

Expected Results:  
Would be better to always open natively-supported images (and other filetypes,
if this problem is universal) in the new browser window.

Comment 2

15 years ago
It's a bug in vBulletin, which uses a bad Content-Disposition HTTP header.

*** This bug has been marked as a duplicate of 183653 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
v.
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.