If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

sometimes clicking on a link makes the browser go BACK instead to the clicked page

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Marcin Gorycki, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030308
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030308

Sometimes when I left-click on a link with a mouse, I am taken to the previous
page instead of the link target. This is terribly annoying, as it happens some
30% of the time.



Reproducible: Sometimes

Steps to Reproduce:
1. open some page
2. click on a link

Actual Results:  
previous page opens

Expected Results:  
link target should open

I don't know if it matters, but I have mouse gestures and radial context menus
installed.

Happens on 1.3 beta as well as on 1.3 RC (I tried two different release candidates).

The same result on XP and W2k

Comment 1

15 years ago
Does the bug happen if you uninstall mouse-gestures?
I never saw this on my system (since M18)
Do you use some kind of proxy ?

Have you tried a build without installed addons ?
use :ftp://ftp.mozilla.org/pub/mozilla/nightly/2003-03-12-11-1.3/mozilla-win32.zip
and uncompress it to a different folder und simple run "mozilla.exe"

Comment 3

15 years ago
Over to History: Session
Assignee: asa → radha
Component: Browser-General → History: Session
QA Contact: asa → kasumi

Comment 4

15 years ago
I'm pretty sure this is caused by mouse gestures, especially if you've set them
to use the left mouse button. Happens to me sometimes since I've installed
gestures and never before.
(Reporter)

Comment 5

15 years ago
Yep, this is mouse gestures. Changing their settings to use middle button got
rid of the problem. 

But now what? Should I submit a bug to mouse gestures folks? Or is it a bug in
mozilla 1.3 triggered by mouse gestures (gestures and moz 1.2 work ok)?
we assume that this is a gesture bug unless a mouse gesture developer reports a
bug report about what is broken in Mozilla.

-> wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: kasumi → docshell
You need to log in before you can comment on or make changes to this bug.