Text entered into the search field in the upper left does not display

RESOLVED FIXED

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Ira, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

Text entered into the search field in the upper left of the front page of the
CNBC website (http://moneycentral.msn.com/investor/home.asp) does not display. 
The cursor moves as letters are entered.  Search results obtained by clicking on
the GO button reveal that the text was successfully entered, but just not displayed.

local HTML source is
<table BORDER=0 WIDTH=100% CELLPADDING=0 CELLSPACING=0>
<tr VALIGN=TOP><td VALIGN=TOP BGCOLOR=WHITE WIDTH=168>
<table CELLSPACING=0 CELLPADDING=0 BORDER=0 ALIGN=CENTER WIDTH=100%>
<tr height=10 BGCOLOR=8E9FD6><td height=10 colspan=2><img
SRC="/inc/images/1x1trans.gif"></td></tr>

<form name="search" id="search" action=/search/searchverify.asp method="get"><tr
BGCOLOR=#8E9FD6><td width=12><spacer TYPE=BLOCK><img
SRC=/inc/images/1x1trans.gif></td><td NOWRAP><span Class=smallfontwhite><label
FOR="q" ACCESSKEY="s"><span CLASS=smallprompt><u
STYLE="accelerator:true;">S</u>earch MSN Money</span></label></span><br><input
type=text id=q maxlength=160 name=q size=8>&nbsp;<input TYPE=SUBMIT VALUE=Go
CLASS=graygobtn>
</td></tr></form>
<tr height=10 BGCOLOR=8E9FD6><td height=10 colspan=2><img
SRC="/inc/images/1x1trans.gif"></td></tr>
</table><br>

In ie 5.0.2920 win2000, text displays as black on a white background.

Reproducible: Always

Steps to Reproduce:
1.Wait for page to fully load
2.Click into text input field using the mouse
3.Type

Actual Results:  
Text entered into the search field does not display.  The cursor moves as
letters are entered.  Search results obtained by clicking on the GO button
reveal that the text was successfully entered, but just not displayed.

Expected Results:  
There should be more contrast between the font and the background, either while
typed or after being highlighted.  Looking at the source, the class
smallfontwhite suggests that the font should be white, but the altenate
background color specification looks like it should be off-white.  Anyhow, you
can read the text in ie 5.0.
Not a problem for me on Linux.  Is there some reason text color is inheriting
into text inputs?
Assignee: font → form
Component: Layout: Fonts and Text → Layout: Form Controls
QA Contact: ian → desale
wfm with win2k build 20030312..
We used to have a bug where negative z-index elements near a text field would
cause these symptoms.... it's been fixed for a while.  Reporter, do you see the
problem with a current 1.3rc build?
(Reporter)

Comment 4

15 years ago
Mozilla 1.3 release March 13, 2003 does not exhibit this bug.  Thanks and sorry
for the out-of-date report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.