imap folder rename oddity with offline use

RESOLVED DUPLICATE of bug 82262

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 82262
15 years ago
2 years ago

People

(Reporter: gweon, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

For any imap folder marked for offline use, I find that if I rename it, then it
is not marked for offline use any more.  Worse, the previously downloaded
messages are not available for offline use any more.  Suppose I renamed folder
"X" to "Y".  If I look in the mail folder, then what I find is that "X" still
exists but "Y" does not (only "Y.msf" exists unless I specifically turn on the
"download for offline use" option for "Y" and download messages).  This behavior
is the same even if I move a folder to inside another folder.  So, as I rename
or move folders around, and turn on the "download" options, I am making lots and
lots of duplicates.  This is in contrast to the cleaner behavior for folders
downloaded from POP servers.

BTW, I have turned on the option "When I create new folders, select them for
offline", which does not have any effect on the renamed or moved folder.

Reproducible: Always

Steps to Reproduce:
1. Suppose I have folder "X" in some imap mail account.
2. I turn on "download for offline use" for "X" and download messages.
3. I rename "X" to "Y" or I move "X" to inside another folder "Z".


Actual Results:  
The "download for offline use" switch for "Y" or "Z\X" is no longer turned on.
The messages that I previously downloaded in "X" are now lost in the messenger.
The actual file "X" still exists in the mail directory of the hard disk.  This
file just is not accessed any more by Mozilla.

Expected Results:  
On rename or move, Mozilla should have renamed or moved the file "X" in the hard
drive to either "Y" or "Z\X".
The "download for offline use" switch and any other switches should have
remained intact.

Comment 1

15 years ago
I'm having the same problem, using Mozilla 1.3
Confirmed Mozilla Thunderbird 0.5+ (20040311)

After renaming the folder the MBOX is also moved to the new name. I think there
was a fix between. Can you confirm this?

But I can see that the offline checkbox is deselected after renaming a imap
folder. I can turn it on and it is working again.

Reporter please test again with a current build.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 237234 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

14 years ago
I just downloaded the most recent version of Mozilla (1.7 beta), and this bug
still remains.

(In reply to comment #2)
> Confirmed Mozilla Thunderbird 0.5+ (20040311)
> 
> After renaming the folder the MBOX is also moved to the new name. I think there
> was a fix between. Can you confirm this?
> 
> But I can see that the offline checkbox is deselected after renaming a imap
> folder. I can turn it on and it is working again.
> 
> Reporter please test again with a current build.
(In reply to comment #4)
> I just downloaded the most recent version of Mozilla (1.7 beta), and this bug
> still remains.

What of this two reported behaviors do you mean? The renaming of the .msf-file,
the unchecking of the checkbox or both?
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > I just downloaded the most recent version of Mozilla (1.7 beta), and this bug
> > still remains.
> 
> What of this two reported behaviors do you mean? The renaming of the .msf-file,
> the unchecking of the checkbox or both?

All of them.

Comment 7

14 years ago
Re-tested using build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
Gecko/20040316 and the bug still remains.  When a folder is previously selected
for offline use and then is renamed, it then becomes de-selected for offline use
and must be re-selected manually.
(In reply to comment #7)
> Re-tested using build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
> Gecko/20040316 and the bug still remains.  When a folder is previously selected
> for offline use and then is renamed, it then becomes de-selected for offline use
> and must be re-selected manually.

So your MBOX file is renamed correctly? I ask because by gweon this file isn't
renamed, like it's told in comment 6. It's something mystic. I don't know why
it's happen and I think a new profile wouln'd help but could you try it gweon?
(Reporter)

Comment 9

14 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > Re-tested using build Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b)
> > Gecko/20040316 and the bug still remains.  When a folder is previously selected
> > for offline use and then is renamed, it then becomes de-selected for offline use
> > and must be re-selected manually.
> 
> So your MBOX file is renamed correctly? I ask because by gweon this file isn't
> renamed, like it's told in comment 6. It's something mystic. I don't know why
> it's happen and I think a new profile wouln'd help but could you try it gweon?

Sorry, by "all of them", I meant all of the things that I reported originally. 
They do *not* include the renaming of *.msf files.  The *.msf files are renamed,
but this has not been an issue at all.  Let me summarize again what the problems
are.

Say I started with the mozilla mail directory containing files X (containing
actual messages) and X.msf (mail summary file?).  Then I rename X to Y in
mozilla.  In the mail directory, X.msf is renamed to Y.msf, but X still remains.
 Moreover, the checkbox for the "offline use" is unchecked for Y now, even when
X started with this checkbox checked.  As I check on this box for Y and download
messages, file Y is created and so on ...  You see, this way, the mail folder
becomes cluttered with mail files that is not actually used after renaming.
Product: MailNews → Core

Comment 10

9 years ago
Indeed using different names and renames I get offline property unchecked. Otherwise, no issue with the messages, all there. But maybe gmail does bit different.

Note that using same original folder X, try to rename Y, I get:
"The current command did not succeed.  The mail server responded: Duplicate folder name [Gmail]/X (Failure)." mybe gmail imap has it's ways bit different, that XY meaning something, but still not correct behavior as I CAN create X or Y with no issue, only not rename.

Comment 11

9 years ago
oh, forgot .. using gmail imap on
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.2pre) Gecko/2008072418 Thunderbird/3.0a2 ID:2008072418
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Updated

9 years ago
QA Contact: grylchan → networking.imap

Updated

6 years ago
Blocks: 391641

Updated

5 years ago
Assignee: dbienvenu → nobody

Updated

5 years ago
No longer blocks: 391641
Depends on: 82262

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 82262
You need to log in before you can comment on or make changes to this bug.