Text displays overwritten

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: Raymond A. Chamberlin, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

All text below the area having a pink background is desplayed on top of the text
in the pink-background area.

The page displays properly with Netscape 4.79.  I know you blame this problem on
the particular sites, for not properly recognizing Mozilla properly; but what
good is Mozilla if it's just a degraded Netscape.  Make the damn thing like
Netscape so it'll display right, whatever!

Reproducible: Always

Steps to Reproduce:
1. Navigate with the above URL.
2.
3.

Actual Results:  
See "Details"

Expected Results:  
Displayed this page as Netscape does.
I see completely identical rendering in Netscape 4 and Linux trunk build
2003-03-09-05.

Comment 2

15 years ago
There is a DIV with the height set to 1007px this is to small for the content
inside.  The table after the DIV starts where the DIV left off and runs over the
DIVs content.

The good thing is that Mozilla is rendering it correctly. :)
(Reporter)

Comment 3

15 years ago
Yeah, Netscape reads minds. . .and Bush is "correct" and the rest of the world
is wrong.
Well... In this case every browser but IE/Windows renders set-height divs the same way,
so in fact the whole world is with Mozilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

15 years ago
The whole world doesn't give a flying whatever about what set-height divs even
ARE, and I didn't even check what IE did with this page.  The point is:  I and
the vast majority of the world would like to use a browser that works at least
as well as Netscape 4.79.  Since this NETSCAPE version rendered the information
correctly that any viewer would want to observe, and Mozilla 1.2.1 did not,
Mozilla is degraded from Netscape's old state of the art.  There's no reason to
bring IE into this picture at all (or whatever set-height divs are -- out of the
lab into this picture).  Do whatever it takes to make it work like Netscape and
forget IE.  And if you're saying that the subject Web page is screwed up on
Mozilla because it was DESIGNED using IE, it still doesn't excuse Mozilla
designers from not designing Moz to do whatever Netscape does that makes even
pages designed under a different religion than Moz people believe in display
totally legibly.  Screw software religions; I just want to read the page.
It's like this:

1)  This page uses a feature that Netscape does not support at all
2)  It misuses this feature because of a but in IE

The only way to act like Netscape would be to drop CSS support completely.  In
which case, why bother writing Mozilla to start with?  Just use Netscape.

This is not a religious issue, but a simple pragmatic one.
(Reporter)

Comment 7

15 years ago
Most people using general-purpose browsers are not reverse pragmatists, as
apparently the above writer is.  There exist _some_ advantages to using Moz and
I thought the idea of Moz was to _improve_ upon Netscape -- in features the
_general_ user uses as well as those used only by specialists or fetishists.  I
don't know what all CSS does for anyone, but I certainly don't believe that the
_only_ way to get Moz to "act like Netscape" -- that is, display pages that are
designed with this sort of problem in IE -- is to "drop CSS."  I am not a
software type at all, but there's no way I'll believe that at least an easily
included _manual_ option couldn't be incorporated in Moz that would allow
legible display of such "imporperly designed" pages.  But I further believe that
it isn't much beyond trivial to include an _automatic_ detection and correction
routine in Moz's software that would make the proper display (that intended) of
such Web pages transparent to this fort of error in them.  Certainly the people
working on Moz have used their talents on Moz and other things to achieve far
more difficult problems.  They're just hung up on throwing purism at an impure
world outside their control, much as religious zealots do.
>  I don't know what all CSS does for anyone

Simple.  CSS is the one existing documented standard for how to render webpages.
 Mozilla is a CSS browser.  That's all.

We should certainly include a "Ignore all author styles for this page" option;
there is a bug on that.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.