Reply/Forward inline: header is garbled when encoding used in header is not same as the one in Content-Type

RESOLVED WORKSFORME

Status

MailNews Core
Internationalization
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: ji, Assigned: smontagu)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

748 bytes, text/plain
Details
(Reporter)

Description

16 years ago
In case the charset in Content-Type is not same as the one in header,
reply/forward inline will have a garbled header since mozilla is looking at the
charset in Content-Type of the original mail first.

Steps to reproduce:
1. Have a mail with header encoded in ISO-2022-JP but charset in Content-Type
for mail body set to us-ascii
2. Select the mail and click on Reply or Forward, you can see the header is
garbled on reply and forward compose window.

Testing mail to follow.
(Reporter)

Comment 1

16 years ago
Created attachment 117219 [details]
A testing mail.
(Reporter)

Comment 2

16 years ago
Comments from Kat:

I can think of a couple of possible ways to fix the problem.

1. A workaround -- not perfect.

Assume the default charset in replies for the 1st MIME part if the charset in
the original is US-ASCII. This will not be perfect but will take care of the
majority of the cases. US-ASCII could be a subset of many different charsets and
to assume ISO-8859-1 in reply for all cases ignores this fact.

2. Separate header charset processing from body charset processing and create
reply headers using the original header charset. Process the body part(s) using
the default charset if it is us-ascii.
Keywords: intl

Comment 3

16 years ago
Another test case if you need it. Using Moz 1.3 release on Linux. Subscribe to
nntp://news.netbeans.org/netbeans.nbusers in Mozilla Mail. Find message "Open
Question about IDE's" (with a non-ASCII apostrophe) from V Leher on 03/07/2003
12:40 PM. Try to reply to it (as I did, though using Moz 1.2.1) and you get a
nonsense character for the last word. Headers from the original message:

Subject: RE: [nbusers] Open Question about =?ISO-8859-1?Q?IDE=B4s?=
Content-Type: text/plain; charset=UTF-8

and in my reply:

Subject: Re: [nbusers] Open Question about =?UTF-8?B?57+9?=
Content-Type: text/plain; charset=us-ascii; format=flowed
Product: MailNews → Core

Comment 4

14 years ago
(In reply to comment #0)
> In case the charset in Content-Type is not same as the one in header,
> reply/forward inline will have a garbled header since mozilla is looking
> at the charset in Content-Type of the original mail first.

It's not clear which header is being referenced here.  Bug 229399 has multiple 
examples of encoded headers (such as Subject: and To:) being mistranslated in 
the header fields of the reply/forward.

However, I think this report is about the header that appears inside the message 
body (e.g., "Jürgen wrote:").  This function is working correctly in current 
builds (e.g. TB 1.0).

=>WFM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.