Java doesn't work in OS X 10.1

RESOLVED WONTFIX

Status

Core Graveyard
Java: OJI
--
major
RESOLVED WONTFIX
16 years ago
8 years ago

People

(Reporter: Dave Dyer, Unassigned)

Tracking

({helpwanted})

Trunk
PowerPC
Mac OS X
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312

Mac osx java seems completely brokn in the 1.3 release.  I used it
regularly in previous releases.   Java is enabled in the preferences,
but "java console" is greyed out in developer tools, and no java applets
are active.  Java applications from desktop and applets from IE
are still working fine.

Reproducible: Always

Steps to Reproduce:
1. go to any java page, note that there is no java
2.
3.

Comment 1

16 years ago
does upgrading to 1.4.1 improve anything ?
http://www.apple.com/java
Assignee: asa → joshua.xia
Component: Browser-General → OJI
QA Contact: asa → dsirnapalli
(Reporter)

Comment 2

16 years ago
java 1.4.1 does not applear to be supported for OSX 10.1.5

Comment 3

16 years ago
bug 97613? (from the 1.3 release notes)
Component: OJI → Browser-General

Comment 4

16 years ago
WorksForMe using FizzillaMach/2003031409. Dave, can you still reproduce this
problem using a current nightly build?
Component: Browser-General → OJI
Summary: java completely broken → Java completely broken

Comment 5

16 years ago
(Also WFM using Moz 1.3.)
(Reporter)

Comment 6

16 years ago
no change with build 2003031408

previous traffic suggests this is related to java 1.4.1 support (lack
thereof) combined with running osx 10.1 vintage.

Comment 7

16 years ago
I'm also having lots of crashes lately, since a week or so. I'm not using Java a
lot, so it could have been caused by an earlier change, or it could have been
caused by the Java 1.4.1 download (which was supposed to be harmless), which I
did on March 11th (2200 GMT). I started nothing the crashes the day afterwards,
but that might be becuase I was trying to test more intensively for Java (untill
I noted that Mozilla wasn't using the new plugin anyway).

At the moment, I'm using a nightly "Mozilla/5.0 (Macintosh; U; PPC Mac OS X
Mach-O; en-US; rv:1.4a) Gecko/20030313" on Mac OS X 10.2.4. Java 1.4.1 in installed.

Mozilla still uses the Java 1.3.1 plugins, and it's so indicated on the "About
plugins" page. Java 1.4.1 shouldn't be used at all. Clearing the Java-cache
doesn't help.

I have repeatable crashes on this page :
http://www.amdzone.com/articleview.cfm?articleid=1254
Talkback-ID : TB203148H

I also have another talkback-ID (TB202338E) which might be different. In that
case I saw that an applet from 1 tab was appearing on another tab, and I crashed
when I tried to close them. But that might be unrelated.

Comment 8

16 years ago
Dave, can you also reproduce this problem using OS X 10.2?

Comment 9

16 years ago
MacOS->beard@netscape.com
Assignee: joshua.xia → beard

Comment 10

16 years ago
*** Bug 201270 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
I have the same problems with MRJ 1.4.1 with Moz 1.4b on OS 10.2.6. (Mozilla/5.0
(Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030507).  Another
example page is www.my-cast.com - the radar images don't appear.

Comment 12

15 years ago
I take back my last comment (#11) - it appears that Java is working again on the
same site.  (www.my-cast.com)  I did delete and re-install the same build of
Mozilla last night, which may have done something for it.

Comment 13

15 years ago
reports of this bug have been a bit confused.
However, the situation is pretty clear to me :
Java is completely broken on MacOS X 10.1 (and MacOS X Server 10.1) with Mozilla versions 1.3 to 
1.6. The same bug arise for recent Camino nightly builds (based on these versions of Mozilla).

The system requirements for Mozilla 1.6 (as seen on mozilla.org) are wrong: Mozilla does not fully 
support MacOS X 10.1.

It is fairly easy to test, so why is this still UNCONFIRMED ?!?

Comment 14

15 years ago
Does this bug only effect OS X 10.1?

Prog.

Updated

14 years ago
Assignee: beard → kyle.yuan
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: dsirnapalli
Summary: Java completely broken → Java doesn't work in OS X 10.1

Comment 15

14 years ago
*** Bug 204192 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
*** Bug 168649 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: kyle.yuan → nobody
Keywords: helpwanted

Updated

13 years ago
Depends on: 298430
Wontfixing 10.1 only bugs (see bug 298430).
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.