Status

RESOLVED DUPLICATE of bug 192780
16 years ago
14 years ago

People

(Reporter: info, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

deleting messages fails, mozilla does nothing - not even hang as usual. ;-)

Reproducible: Always

Steps to Reproduce:
1.n/a
2.
3.

Comment 1

16 years ago
For me the /first/ deletion works, but none afterwards. When Mozilla denies
deleting new messages (it does simply *nothing*), it is also unable to display
another message from the same folder. Clicking on another Mail folder and then
back to the first fixes that, but it is still impossible to delete any further mail.

Comment 2

16 years ago
You can't even move the Message you want to delete to the "Trash", simply
nothing happens then. But if you do that action (and nothing happens) and you
move *another* mail to any other Mailfolder excluding "Trash", the latter mail
is moved _and_ the first mail, which should be deleted, is moved to "Trash". The
message selection display is *not* updated after this happend!

Comment 3

16 years ago
Using trunk build 20030318 on winxp, linux and macosx deleting mail messages
works for me on IMAP and POP accounts.  Reporter, can you try a more recent
build, if it's still broken for you give more information.  Type of account, is
message being deleted from Inbox or other folder, what level?
(Reporter)

Comment 4

16 years ago
The problem disappeared after I deleted my profile and re-created it. The
problem occured with messages from INBOX on a ssl'ed IMAP session.

Comment 5

16 years ago
The actual nightly crashes on my system, so I am unable to verify if this bug is
still in a newer build than mine (1.3 final).

I'm using a simple POP-Account and it happens with /any/ mail folder.

And I don't want to delete my profile as I'm using Mozilla as my mail archive. :)

Comment 6

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

I have the same problem as #1, only the problem appears intermittant.
The only fix I've found is to shutdown mozilla completely,
after a restart the problem is gone (most times).
Although I can not be 100% certain, the problem seems to be linked to mozilla
(on startup) asking me if I want to compact my folders. When I answer yes, the
problem often (always?) appears.
I've had this problem with 1.3a and 1.3b, and I download all my mail to my local
mail folders.

Comment 7

16 years ago
With 1.4a, the Problem is nonexistent.

Comment 8

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

The problem is (for me) still there in 1.4a!

My setup:
- Mozilla 1.4a .tar.gz package from mozilla.org
- Red Hat 8
- home directory/local mail folders on nfs
- remote pop3 mailserver
- my settings/mail folders have been migrated from netscape 3.0 (irix) via
  netscape 4.x/6.x to mozilla 1.x (I have only had mail problems with mozilla)

My session:
- Mailnews reader open (without problems so far, mail read/deleted,
  news read)
- New mail coming in -> select Inbox folder, 'Get Msgs' -> 1 new message
  -> read new message

1a Press 'Delete' button -> nothing happens (except for the visual hints), or
1b Press 'del' on the keyboard -> nothing happens, or
1c Select 'Edit' menu -> 'Delete Message' -> nothing happens, or
1d Context menu (mouse button 2 in message or folder window)
   -> 'Delete Message' -> nothing happens
2  Select other mail message in same folder (with mouse or keyboard)
   -> mail is highlighted, but not displayed (display is stuck
   at last message read)
3  Select other folder -> messages can be selected and read normally

- Until I quit Mozilla, the reader is stuck in the above loop 1 -> 2 -> 3
- While in 'condition 2', 'Get Msgs' shows the new messages in the folder,
  but they are not displayed until after step 3

I have another problem that might be related (at least,
this time it appeared right after the above problem):
When I'm sending an E-mail, the process gets stuck at 'Copying message to
Sent folder' (indefinitely). When I 'Cancel', I'm back at the compose window.
The message has been sent correctly however, just not copied to my Sent folder.

During all this time, the nfs and pop3 servers have been up and running
normally, and mozilla is the only programming accessing the mail folders.

Comment 9

16 years ago
This appears to be a duplicate of Bug 192780 (applies to POP mail only). It has 
been fixed in 1.4a and subsequent nightly builds, and will be part of the 1.3.1 
release as well. For a workaround, see Bug 184959 Comment 19.

However, Robert Eggermont, you seem to have a different problem.

Comment 10

16 years ago
(Un)fortunately, I have not been able to trigger the bug since my last post,
so maybe it was just something left behind by 1.3 in my .msf files?
I'm happy for now.

*** This bug has been marked as a duplicate of 192780 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.