Closed Bug 197506 Opened 18 years ago Closed 15 years ago

Collapsing and expanding news thread in "view unread" mode loses recently read messages.

Categories

(SeaMonkey :: MailNews: Message Display, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mib, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Read news in "View -> Sort by -> Thread" and "View -> Messages -> Unread" mode.
 Read a child message in any thread, then collapse the thread and expand it
again.  The read message is no longer shown.  You could argue that this is
semantically correct, but it is not the expected behaviour.  Messages should
never be removed from display without the user leaving and re-entering the
newsgroup.

Reproducible: Always

Steps to Reproduce:
1. Read connect to a news server and select a group with some threads.
2. Choose "View -> Sort by -> Thread".
3. Choose "View -> Messages -> Unread".
4. Read a child message in any thread.
5. Collapse the thread.
6. Expand the thread.

Actual Results:  
Child message read in this session is gone.

Expected Results:  
Child messages read in this session should remain, and display unhighlighted.

Present in at least 1.2, 1.2.1 and 1.3, and probably earlier.
Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
This has been a problem since early Spring and still exists as of Build 20030513
Trunk 5...
Blocks: 236849
Product: Browser → Seamonkey
Assignee: sspitzer → mail
This WFM. Messages newly marked as read stay unless I leave the folder.  Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060101 SeaMonkey/1.5a  Also don't see Thunderbird equivalent Bug 248144

Mike do you see this problem using Seamonkey 1.0?

However, an ancillary issue is "mark all read" does not mark the children of a collapsed thread as read. (Thunderbird Bug 321435)
QA Contact: esther
Confirm WFM in Seamonkey 1.0.
mark WFM
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
No longer blocks: 236849
You need to log in before you can comment on or make changes to this bug.