If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reloading during form submission submits and resets form with filled-in values

RESOLVED DUPLICATE of bug 819648

Status

()

Core
HTML: Form Submission
--
minor
RESOLVED DUPLICATE of bug 819648
15 years ago
5 years ago

People

(Reporter: Nicholas Allen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
WinXP 0312 cvs trunk

I was adding a cc to a bug and accidentally reloaded right after submission. 
The submission completed successfully and the reloaded page still had all of the
form contents filled in.  I think the form should keep the contents only if the
submission doesn't happen and reset the form if submission was successful.

Steps:

Fill in form.
Submit form and reload during submission.

Expected:

Form information retained if reload was before submission.
Form information cleared if reload was after submission.

Actual:

Form information retained and form submitted.

Comment 1

14 years ago
This sounds a lot like Bug 46845, especially if the form was submitting to the
same URL that was used to draw the form.

Comment 2

12 years ago
I have this bug also with Firefox 1.03 and 1.5 on Fedora 3.  After submitting the form I refresh the page, which reexecutes the CGI program associated with the form.  The CGI program has a blank value as the defsault form value, but Mozilla displays the submitted value.  IE 6 works fine.
Assignee: form-submission → nobody
QA Contact: ashshbhatt → form-submission
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 819648
You need to log in before you can comment on or make changes to this bug.