Closing a tab should bring me back to the last tab I was using and not the right-most one

RESOLVED DUPLICATE of bug 144207

Status

RESOLVED DUPLICATE of bug 144207
16 years ago
10 years ago

People

(Reporter: err, Assigned: jag-mozilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Typically I use the middle-click function to open up links in a new tab in the
browser. When I close the newly opened tab, I would expect to be brought back to
the tab I was last viewing and not the right-most one.


Reproducible: Always

Steps to Reproduce:
1.Open up 2 or more empty tabs
2.In the left-most tab, type in http://www.mozilla.org
3.Middle-click on one of the items in the left-hand menu
4.Close the newly opened tab

Actual Results:  
I am brought to the right-most remaining tab

Expected Results:  
It should have brought me back to the tab I left (in this case, the left-most one).

I could be nice, if there was some kind of "tab-history", which kept track of
the order in which the tabs was being viewed. Then, when I closed a tab the
browser would bring me back to the tab I was last viewing.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 144207 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Also see bug 115215, which is still open, that proposes a keyboard shortcut to
get to the last used tab (without closing the current one however).
(Reporter)

Comment 3

16 years ago
I don't understand why bug #144207 is a WONTFIX, given all the freeback on the
subject. I find the behaviour I described natural in using the tabs feature,
just bringing me to the right-most tab must be confusing to users.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.