the make process breaks because nsinstall complains about existsing files - actually it looks like it tries to create a symlink to .

VERIFIED INVALID

Status

SeaMonkey
Build Config
--
major
VERIFIED INVALID
16 years ago
14 years ago

People

(Reporter: Jens-Woflhard Schicke, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       w3m/0.2.1
Build Identifier: source code of Mozilla 1.3 on www.mozilla.org

After doing a ./configure the make process ends after the following output:

cd md; make export
make[5]: Entering directory `/mnt/data/software/mozilla/nsprpub/pr/include/md'
../../../config/./nsinstall -R -m 444 ./ /mnt/data/software/mozilla/dist/include/nspr
../../../config/./nsinstall: cannot make symbolic link /mnt/data/software/mozilla/dist/include/nspr/.: File exists
make[5]: *** [export] Error 1
make[5]: Leaving directory `/mnt/data/software/mozilla/nsprpub/pr/include/md'
make[4]: *** [export] Error 2
make[4]: Leaving directory `/mnt/data/software/mozilla/nsprpub/pr/include'
make[3]: *** [export] Error 2
make[3]: Leaving directory `/mnt/data/software/mozilla/nsprpub/pr'
make[2]: *** [export] Error 2
make[2]: Leaving directory `/mnt/data/software/mozilla/nsprpub'
make[1]: *** [nspr] Error 2
make[1]: Leaving directory `/mnt/data/software/mozilla'
make: *** [default] Error 2

Actually to me it looks like nsintall tries to create a symlink names . but i maybe wrong...

I am using
GNU Make version 3.79.1, by Richard Stallman and Roland McGrath.
GCC 2.95.3
and tried to compile
Mozilla 1.3 (the sources from www.mozilla.org)

           Jens-Wolfhard Schicke


Reproducible: Always

Steps to Reproduce:
1. download the source... tar -xjvf mozilla-source-1.3.tar.bz2
2. ./configure --host=i686
3. make

Actual Results:  
As described the make process stops...


Expected Results:  
Instead i expected mozilla to compile (who wouldn't)
Severity: blocker → major
You confused NSPR by giving it an invalid --host configuration.  --host
parameters are only required when cross-compiling.  And (just to cover all
bases), the optimization level does not change dependent upon which processor
you choose (ie, i386 vs i686). You need to pass the proper compiler flags to
--enable-optimize for that. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

15 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.