PalmSyncInstall.exe (Address Book Palm Sync) has no customized icon (in Start Menu)

VERIFIED FIXED

Status

--
enhancement
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: sgautherie, Assigned: ssu0262)

Tracking

({icon})

Trunk
x86
Windows 95

Details

(Whiteboard: [adt2])

Attachments

(5 attachments, 3 obsolete attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3) Gecko/20030312

(no details: rfe !)


Reproducible: Didn't try

Steps to Reproduce:
1. ((custom) Installed Mozilla)

Actual Results:  
In 'Start > Programs > Mozilla' menu, both 'A. B. P. S. Install' and  'A. B.
P. S. uninstall' have a default "windows program" icon (from Shell32.dll).


Expected Results:  
Add and use a customized icon.

Comment 1

16 years ago
confirmed 1.3 final
this can be fixed easily.

jglick: is there an icon available? the lack of an icon makes it look really
unprofessional, if you aren't adventurous you'd think the program wasn't
installed at all.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted, icon

Updated

16 years ago
Summary: [RFE] PalmSyncInstall.exe (== 'Address Book Palm Sync') has no customized icon (in Start Menu) → PalmSyncInstall.exe (Address Book Palm Sync) has no customized icon (in Start Menu)
Fixing in bug 192703
Depends on: 192703
(Reporter)

Comment 3

16 years ago
Reply to comment 2:

Agreed, with your bug 192703 comment 9: "palmsync needs to have icons in the
install program to use".

PS: I would say that the current bug (lake of icon) should block bug 192703
(install script fix), and reverse the current dependency way :->
(Reporter)

Comment 4

16 years ago
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401]

Bug still there.
(Reporter)

Comment 5

16 years ago
NB: With v1.4a, the menu path is now 'Start > Programs > Mozilla > Palm Tools'.
The bug is still there because there is no patch fully finished yet.

Comment 7

16 years ago
adt: nsbeta1+/adt2

Rafael to get the icons,  Once icons arrive please work with Marlon for
verification/icon approval and with Sean to check in the custom icon (by
reassigning the bug to Sean).  Thanks.
Assignee: rdayal → rebron
Keywords: nsbeta1+
Whiteboard: [adt2]
(Reporter)

Comment 8

16 years ago
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4b) Gecko/20030507]

Bug still there. (with v1.3 profile, at least)

(Re comment 6: this is again a reminder status report, not a complain.)
Created attachment 124467 [details]
Icon from 4.x
The questions now are:
ideally is there time to modify what I have attached 
should we used what I have attached from 4.x, or rephrased is that better than
what's there now?

Assignee: rebron → ssu
I can't see what you have attached.
Created attachment 124591 [details]
Icon take two
Attachment #124467 - Attachment is obsolete: true
I dunno why, but it doesn't display in Mozilla, or in MSDEV, but does on the
desktop.
(Assignee)

Comment 14

16 years ago
Created attachment 124755 [details]
real icon

Turns out that the previous icon attachment was a .rc file.  This one just
contains the .ico.

Rafael, is this a mozilla, commercial/ns, or project neutral icon?  It looks
like it's an icon from 4.x.
(Assignee)

Updated

16 years ago
Attachment #124591 - Attachment is obsolete: true
Created attachment 124790 [details]
Giovanni template

Its up to ssu, but we should use Giovanni style, imho. Here is the template,
can you superimpose the tools on that?
Comment on attachment 124755 [details]
real icon

Changing MIME Type to image/x-icon so it displays properly in mozilla.
Attachment #124755 - Attachment mime type: image/ico → image/x-icon
Created attachment 124792 [details]
install

These are ones I selected a while ago for the tools for the other patch I'm
working on. Its always flexible though, just requires a file replacement, a 5
second job.
Created attachment 124794 [details]
And uninstall

uninstall
what do you think? if you aren't able to, i can throw the giovanni template i
made, and the tools together. Or we could go with the standard setup icons.
(Assignee)

Comment 20

16 years ago
Created attachment 125117 [details] [diff] [review]
patch v1.0

this patch will add the .ico to the final .exe file.
(Assignee)

Comment 21

16 years ago
Comment on attachment 125117 [details] [diff] [review]
patch v1.0

got rs=sgehani
seeking sr=
Attachment #125117 - Flags: superreview?(jaggernaut)
Attachment #125117 - Flags: review+
(Assignee)

Comment 22

16 years ago
Created attachment 125121 [details] [diff] [review]
patch v1.1

better patch.  it now compiles in two .ico files (installer and uninstaller
icons) and also updates the shortcut creation to use the right icon.
Attachment #125117 - Attachment is obsolete: true
(Assignee)

Comment 23

16 years ago
Comment on attachment 125121 [details] [diff] [review]
patch v1.1

got r=sgehani
seeking sr= now
Attachment #125121 - Flags: superreview?(jaggernaut)
Attachment #125121 - Flags: review+
(Assignee)

Updated

16 years ago
Attachment #125117 - Flags: superreview?(jaggernaut)
Comment on attachment 125121 [details] [diff] [review]
patch v1.1

sr/a=sspitzer
Attachment #125121 - Flags: superreview?(jaggernaut)
Attachment #125121 - Flags: superreview+
Attachment #125121 - Flags: approval1.4+
(Assignee)

Comment 25

16 years ago
patch checked in to both trunk and branch using NeTDeMoN's install.ico and
uninstall.ico
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: fixed1.4
Resolution: --- → FIXED

Comment 26

16 years ago
Trunk and Branch build 2003-06-10: Win2k
Verified Fixed.
Status: RESOLVED → VERIFIED
Keywords: fixed1.4 → verified1.4
(Reporter)

Comment 27

16 years ago
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4) Gecko/20030612]

(As reporter)
Confirming fixed.

Changing:
*bug 192703: 'depends on' -> 'blocks'.
Blocks: 192703
No longer depends on: 192703
Product: MailNews → Core
Product: Core → MailNews Core

Updated

10 years ago
Component: Palm Sync → Palm Sync
Product: MailNews Core → MailNews Core Graveyard
(Reporter)

Updated

10 years ago
Keywords: helpwanted
You need to log in before you can comment on or make changes to this bug.