UserID and Password entered are remembered per-newsgroup instead of per-account

VERIFIED DUPLICATE of bug 36816

Status

SeaMonkey
MailNews: Account Configuration
--
major
VERIFIED DUPLICATE of bug 36816
15 years ago
13 years ago

People

(Reporter: Scott, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

I have to re-enter my UserID and Password over and over again when accessing my
news server because it requires authentication.  I have enabled the ability for
it to store the passwords for my newsgroups, but it treats each newsgroups as a
NEW area and prompts me for the authentication password again.  There should be
a setting that forces it to use the ID and password entered at the Account
Mananger screen.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
I also store the newsgroup userID as well.  It also asks for that as well for
each newsgroup accessed.

Comment 2

15 years ago
this looks lika an enhancement request to me, not a bug, not a major bug anyhow
(Reporter)

Comment 3

15 years ago
No.  It asks for the password when I first open the mail/News client.  Then for
each newsgroup I go into, it asks for the same information again and again even
in the same newsgroup.  It never remembers the UserID and Password even when you
say store it.  I would think it would use the UserID and password that I used to
first connect to the news server with.  Is this by design?  If so, then make
this a request.

Comment 4

15 years ago
Steps to reproduce this issue:
1. Create an account for a server requiring authentication.
2. Add newsgroups.
3. When prompted, enter username and password and mark the remember password
options.
4. Look at the Password Manager and you will notice that the passwords are stored.
5. Wait a while (so that your login times out).
6. Choose a newsgroup.
7. Mozilla will prompt you for username and password and then download headers.
 Enter your username and password and mark remember.
8. Look at Password manager.
9. You will see news://(account)/(newsgroup) with stored passwords.

Actual Results:
Mozilla is storing username and password separately for each news:// URL.

Expected Results:
Mozilla should be storing usernames and passwords for only the account and using
them for each newsgroup.

Requesting 1.4 blockage because this is very annoying to users.  It also creates
the illusion that news authentication is severely broken when it comes to
remembering passwords.

I was prompted to search for and elaborate on this bug by the message thread
starting with message ID: <20030329200941.866$GF@news.newsreader.com>.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.4a?
Keywords: clean-report
OS: Windows 98 → All
Hardware: PC → All
Summary: UserID and Password entered are not remembered correctly → UserID and Password entered are remembered per-newsgroup instead of per-account

Comment 5

15 years ago
This is a dupe of bug 36816.

Comment 6

15 years ago
Yes, this does look like a duplicate.  Wonder why I couldn't find it when I was
searching.

*** This bug has been marked as a duplicate of 36816 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Flags: blocking1.4a?

Comment 7

15 years ago
I am having a similar problem with the group
nntp://news.eclipse.org/eclipse.tools.  Every so often is asks me to enter my
user name and password even though I ask the password manager to manage the
username and password.

I checked the password manager and noticed that the server/group is listed but
the username and password are listed as "<>" (empty angle brackets) when I
expect to seem my actual username and password.

I am not sure that I would list this as an enhancement or "resolved" as above as
it appears that the password manager is not functioning properly.

Comment 8

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.