If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When I click submit, It just Pulls up the Same page.

RESOLVED DUPLICATE of bug 197663

Status

()

Core
HTML: Form Submission
--
minor
RESOLVED DUPLICATE of bug 197663
15 years ago
15 years ago

People

(Reporter: Andrew, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030315
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030315

What is wrong with this code:

<form name = "d474"
<p><select name="d203" size="1">
<option selected value="index.php">Home</option>

[Snip]

</select>
<INPUT type="Submit" value="GO!"
onClick="location=document.d474.d203.options[document.d474.d203.selectedIndex].value"></p>
</form>.

This code is supposed to redirect the user to the page specified by the Value
string in the entry they selected. Internet Explorer renders this flawlessly,
but Mozilla just pulls up the page the form is on (the index page). Am I using
Browser-Specific tags, or is Mozilla's form rendering system diffrent than
Internet Explorers, or What? Please halp!



Reproducible: Always

Steps to Reproduce:
1.
2.
3.




I am using Mozilla Build 2003031508, With the Default Skin on.
(Reporter)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 197663 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.