Switch alt+scroll down/up with shift+scroll down up

VERIFIED FIXED in Firebird0.7

Status

()

--
enhancement
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Lil46john, Assigned: bugzilla)

Tracking

unspecified
Firebird0.7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030316

According to this table http://texturizer.net/phoenix/mouse.html IE and Opera
use Shift+Scroll Down/Up for Back. Phoenic uses Alt+Scroll Down/Up. Makes sense
to be with the rest.



Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

16 years ago
Blocks: 197704

Updated

16 years ago
Severity: normal → enhancement

Comment 1

16 years ago
Personally, I would say Alt is more appropriate than Shift since Alt is also
used with the arrow keys to act like Back and Forward shortcuts. However, this
is a valid rfe, so I'm confirming it.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
For me, this is WONTFIX, since shift+scroll is already bound to a shortcut, and
I see no reason of changing it.
(Reporter)

Comment 3

16 years ago
I know that shift+scroll is already a shortcut, but the reason I'm filing this
is so that Phoenix can be IE'ish.

Some shortcuts like ctrl+v=paste don't make sense, but they're standard and I
like standard.
(Reporter)

Comment 4

16 years ago
Is there a reason why shift+scroll=scroll 1 line?

Is that an OS thing?
(Assignee)

Comment 5

16 years ago
I understand David's point but I agree that we should change this.  Our
incompatibility with IE and Opera sticks out like a sore thumb, especially
considering we match ctrl+scroll.  I've just changed it so alt+scroll scrolls
one line at a time (I can't even find an app that offers this), and shift+scroll
goes through session history.

Fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Phoenix0.7
You need to log in before you can comment on or make changes to this bug.