reduce number of mail toolbar buttons by default, reorder delete & junk buttons

VERIFIED FIXED in mozilla1.4alpha

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
15 years ago
6 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
mozilla1.4alpha
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment)

reduce number of mail toolbar buttons by default [but leave junk button]
accepting, transfering adt status from bug #191477
Status: NEW → ASSIGNED
Whiteboard: [adt2]
Target Milestone: --- → mozilla1.4alpha

Comment 2

15 years ago
I'm not sure what toolbar buttons you want to remove.  Currently we match the
Mail toolbar spec except that we have added the necessary Junk button.  Bug
191477 doesn't tell us which button we want to remove.  The Junk Mail spec shows
that we should remove the Next button.  Is this the button in question for this
bug? 

Comment 3

15 years ago
I'd recommend File, Print and Stop to be off by default.

File - DnD is much more common, plus, Move/Copy is also available in Message
menu and context menu.
Print - For most users, printing out msgs is a less frequent action. Available
via File menu and context menu.
Stop - I hope its rare that we take so long to load a msg that Stop is often
nec. (I'd also love to see Stop moved to the status bar as a small icon next to
the progress meter). 

Keep in mind users can turn these back on if desired. Just makes for a less
crowded/overwhelming toolbar on first usage.

I also think we should swap Junk and Delete buttons (see spec) so that Delete is
the far most right button by default. Makes this high frequency button an
easy/fast target.
> I also think we should swap Junk and Delete buttons (see spec) so that Delete is
the far most right button by default

will do, and the other things.

cc asa, who asked for this a while back (and I think logged a bug)
Created attachment 117982 [details] [diff] [review]
patch
Summary: reduce number of mail toolbar buttons by default [but leave junk button] → reduce number of mail toolbar buttons by default, reorder delete & junk buttons
fixed.  this has r/sr=bienvenu, a=jglick
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 7

15 years ago
RE comment #2: "The Junk Mail spec shows that we should remove the Next button."

I don't use "Next" for mail, but always use it in Newsgroups. Hopefully, there
is a way to keep "Next" ON by default (at least) in Newsgroups.

RE comment #3: "For most users, printing out msgs is a less frequent action."

My parents (~70 yrs old) print out almost ALL their e-mails. Corporate users
often print out all their important correspondence. Pleae leave "Print" button
ON by default.

PS. In Newsgroups, please swap "Mark" and "Junk" buttons so that "Next" and
"Mark" buttons are next to each other. It makes much more sense that way.
--> ... | Forward | File | Next | Mark | Junk | Print | ...

--> REOPEN ?

Comment 8

15 years ago
*** Bug 198934 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
Using trunk build 20030325 on winxp macosx and linux this bug is verified per
fix per spec on 3-24 @ 00:54.  Peter, the request you listed after this fix went
in should be written up in a new bug. Note, we kept the Next button as default,
at least Print can be easily returned to the toolbar via Preference but the
swapping of Junk and Mark will need a new bug. Verified
Status: RESOLVED → VERIFIED

Comment 10

15 years ago
OK, I just filed bug 199262 (make "Next" and "Mark" buttons are next to each
other). Should be trivial to fix(?).

PS. I still think it was a mistake to turn off the *Print* button by default.
Printing the only _bridge_ between the virtual and the real worlds.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.