Partial freeze then crash with jre 1.4.1_02 when applet loading

VERIFIED INVALID

Status

Core Graveyard
Java: OJI
--
critical
VERIFIED INVALID
15 years ago
8 years ago

People

(Reporter: irongut, Assigned: Joshua Xia)

Tracking

({crash, stackwanted})

Trunk
x86
Windows XP
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2] TB18155768X, Java1, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Visit URL and java (jre 1.4.1_02) freezes browser when loading. Browser lets me
open + switch tabs, minimize/restore and press buttons but doesn't load any
pages. Doesn't bomb until I close the tab with above URL`or the browser.



Reproducible: Always

Steps to Reproduce:
1. Visit URL
2. Wait till partial freeze, check Moz icon
3. Check out tabs and buttons, nothing works
4. Close tab containing URL... CRASH

Actual Results:  
While applet loading or initialising browser kinda freezes. Moz icon stops
animation, allows creation or switching tabs, buttons look like they work,
minimize and maximize ok but no pages will load. Once you close the tab with the
URL or the browser it bombs to windows which tries to send MS an error report.

Expected Results:  
Load + run the java applet.

Windows XP Pro 5.1.2600

Exception Information:
Code: 0xc0000005	Flags: 0x00000000
Record: 0x0000000000000000	Address: 0x000000006d3d6c37
jvm.dll Offset: 00096c37

Java Console:
Java(TM) Plug-in: Version 1.4.1_02
Using JRE version 1.4.1_02 Java HotSpot(TM) Client VM
in getParameters()
***********Set images path to: http://getcreative.hp-webworld.com/uk/eng/
http://getcreative.hp-webworld.com/uk/eng/fontList.ser
0
left getParameters()
http://getcreative.hp-webworld.com/uk/eng/colours.txt
http://getcreative.hp-webworld.com/uk/eng/fonts.txt
Font class: java.awt.GraphicsEnvironment
aleia
angelots
arial
ashley inline
atmosphere
bailey'scar
balthazar
basehead
battlestar
cancun
caraway
charlesworth
chemical gus
comicsans ms
comicsans
courier new
dancestep
dayton
demun lotion
deportees
earth
edgewater
eileencaps
embargo
federationstarfleet
fielddayfilter
firecat
flotsam stiffupper
galaxy
gilligans island
golden girdle
goodbyecruel world
hacker argot
halcyonia
heather
homesweet home
idsupernovasw
induction
invisiblekiller
italian cursive, 16thcentury
j.d.
jazz let
joy circuit
jungleleaves
kablam!
kellyag
kellyanngothic
keypunch
kramer
lcd
let's eat
lithograph
lunasol
mandarind
marlboro
metolurgy2
minisystem
nasal
neon lights
new brilliant
nightporter
oldtypewriter
oliver
omegaoldface
oracle
paint boy
paraaminobenzoic
pastor ofmuppets
precision
quadaptor
quadrangle
quinquefoliolate
quixotic
raceway
riot act
rocky
ruachle
sadfilms
salter
sambais dead
sand
tahoma
tenderleaf
terminator two
tetanus
times new roman
tinsnips
uechi
ultrasonic
univox
univoxbi
unsteady oversteer
valeshadow
varsity
venus rising
verdana
viking
wakebake
walrod
warren
wet pet
xenotron
xenowort
x-files
xolto
yadou
yawnovision
ybandtuner
yellow pills
z dabbledown
zerohour
zoom
zyberbob
setting label.enter to enter your text
setting label.ftype to font type
setting label.fcolour to font colour
setting label.fstyle to font style
setting label.fsize to font size
setting label.falign to align
setting label.bgcol to background colour
setting style.regular to regular
setting style.bold to bold
setting style.italic to italic
setting style.bolditalic to bold/italic
setting align.left to left
setting align.right to right
setting align.center to center
setting error.imagesdisabled to Inserting images is disabled for this panel
setting error.textdisabled to Inserting text is disabled for this panel
setting error.texttoowide to The text is too wide for this panel
setting error.textwidefromposition to The text is too wide from this position
setting error.parametererror to There was an error in your parameters.  Please
check them and try again.
setting error.visitallpanels to You must visit all editable areas before going
to preview or print.
setting message.genpreview to Preview...

Comment 1

15 years ago
Confirming with Mozilla 1.3 on WinXP

I am unable to successfully transmit the talkback info.  Reporter, if you can,
please do so and post the talkback id in this report.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
(Reporter)

Comment 2

15 years ago
Talkback servers rarely seem to respond but this incident was sent eventually.

ID = TB18155768X

Comment 3

15 years ago
->OJI (I think)
Assignee: asa → joshua.xia
Component: Browser-General → OJI
Keywords: stackwanted
QA Contact: asa → dsirnapalli
Whiteboard: TB18155768X

Updated

15 years ago
Whiteboard: TB18155768X → TB18155768X, Java1

Comment 4

15 years ago
Need some traction on this bug. Dharma can you supply the stack trace from talkback?
Keywords: nsbeta1

Comment 5

15 years ago
After I debugged this applet further, I found it is a well-known issue. 
Basically the applet calls "getWindow" in its "init" method. Java Plug-in 
dispatch this event (getWindow) to the browser thread and wait for it to 
execute it. However, the browser thread is trying to get the applet object at 
this time, unless applet finishes loading, the browser thread will have a 
chance to execute the "getWindow" call.

The workaround to this issue is to put "getWindow" call in its "start" method.

Comment 6

15 years ago
adt: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: TB18155768X, Java1 → [adt2] TB18155768X, Java1

Comment 7

15 years ago
Xiaobin
So what should we do with this bug. Should we mark it INVALID.

Comment 8

15 years ago
Yes, please mark it as INVALID since we don't have a short term solution for that.

Comment 9

15 years ago
Based on comment #5 and comment #8 marking INVALID.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 10

15 years ago
-- Marking VERIFIED.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.