Next Tab shortcut conflicts with Universal Access with French Keyboard

RESOLVED FIXED

Status

Camino Graveyard
General
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: Paul Guyot, Assigned: saari (gone))

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030314 Chimera/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030314 Chimera/0.7+

Next Tab shortcut, which I think is counter intuitive (I nearly asked on the
mailing list if there was one), conflicts with MacOS X Universal Access Zoom Out
shortcut.

Please note that it's probably related to bug
http://bugzilla.mozilla.org/show_bug.cgi?id=170155

Reproducible: Always

Steps to Reproduce:
1. Switch to French or French numerical keyboard
2. Check that } is obtained with option + the second key on the left of the
delete key. - is obtained with the first key on the left of the delete key.
3. Press command+option+[first key on the left of the delete key] to see the
Zoom In.
4. Press command+option+[second key on the left of the delete key] to see the
Zoom Out. Oh! this was the shortchut for next tab.


Expected Results:  
I admit that Apple doesn't implement the shortcuts they pretend to. Still,
Camino should use a better shortcut like Command+> and Command+< which is much
easier to produce on most keyboards. What I really tried was command+optio+tab
since I'm used of tab and shift+tab to navigate through MT-NewsWatcher's commands.

Comment 1

16 years ago
note: this is camino-specific version of this bug
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
About the command-> and command-shift-> suggestions.
I wasn't fresh this morning. These shortcuts are OS X 10.2's cycle thru windows
default shortcuts.

Better shortcuts would be command+&#8805; and command+&#8804;. I've tested them on a dozen
of keyboards: these characters can often be obtained with the key(s) than < and
> but different modifiers or with keys next to those required for > and < but
with the same modifiers (this is the case with Canada CSA). They never conflict
with Universal Access.
shouldn't the french version have localized shortcuts? take that up with the
french localization team, no?
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

15 years ago
Er. What's the link between Camino in French and using Camino with a French keyboard?

Why would I have to use Camino in French to get working shortcuts?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
landed cmd-opt-left/right arrow as replacements. i'm sure these will conflict in
new and totally different ways.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.