If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Form text input element height incorrectly sized

VERIFIED INVALID

Status

()

Core
Layout: Form Controls
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: Ben Darlow, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Where the size of a text-input box is specified via cascading style sheets, the
vertical height is a few pixels higher than it should be, whereas the height for
all other form elements is correctly set as-per CSS rules.

Additional examples can be seen here:
http://macromedia.com/help/accessibility.html
http://www.kapowaz.net/w3c/

Reproducible: Always

Steps to Reproduce:
1. Create a form with an <input type="text" /> element
2. Create a CSS rule for that text element with a specific height
3. Load this page, sit back and marvel/despair.

Actual Results:  
The <input type="text" /> element has an incorrect (oversized) height.

Expected Results:  
The element should have been the specified height.

This bug appears in Mozilla 1.3/Win final, but didn't appear to happen in any
prior version of Mozilla (although I don't have any to hand for testing, and
would rather not have to reinstall to do so). The bug however doesn't appear in
Phoenix 0.5/Win, but does appear in the latest Phoenix/Win night build,
supporting the theory that this is a recently introduced bug.
Actually, the new rendering is identical to the IE6 rendering.  And it's more
compliant with the CSS spec.  See bug 184478.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

15 years ago
I'm somewhat confused here how the behaviour could be identical to IE6. Please
refer to the two screenshots:

http://oldpeculiar.org/etc/form_input_text_ie6.png (26Kb)
http://oldpeculiar.org/etc/form_input_text_moz13.png (33Kb)

The height of the text input box is clearly different in Mozilla 1.3. Can
someone verify that this is the behaviour seen for them in Mozilla 1.3 and that
I'm not the only one to get it?
The website in those screenshots and your testcase have one important difference
-- the website has a <base> tag before the <!DOCTYPE>.  This puts IE in "quirks"
mode but leaves Mozilla in standards mode.  The renderings are identical as long
as both browsers are in the same mode (as they are with that testcase).  When
they are in different modes the renderings are, of course, different.

Comment 4

15 years ago
the kapowaz.net page is also rendered by IE in quirks/compatibility mode, due to
the <?xml version="1.0" encoding="iso-8859-1"?> before the doctype.

moz was getting it wrong before, IE is getting it wrong deliberately because of
the quirks mode - if these pages aren't supposed to look the way they do, they
should be changed so they do the desired thing in standards mode...

verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.