window.open opens child window UNDER parent window, rather than OVER parent window

RESOLVED DUPLICATE of bug 192454

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 192454
16 years ago
15 years ago

People

(Reporter: C Bass, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

When calling for a child window with window.open as in the following example
(this example code has been in use for several months now):

<A href="#photos"
onClick='window.open("../resenlarge.cgi?prop=GranthamCape&photo=GranthamCape1","MultWin",
"toolbar,resizable,scrollbars,HEIGHT=400,WIDTH=500")'><IMG
src="./GranthamCape1m.jpg" alt="Photo" align=center width=200 height=121></A>

child window correctly opens OVER parent window in ALL browsers, including
PRE-Versions 1.3 of Mozilla.  In Version 1.3 of Mozilla, child window
incorrectly opens UNDER the parent window.

Reproducible: Always

Steps to Reproduce:
1. Go to URL:  http://www.irenet.com/nh/residential/GranthamCape/
2. Click on photo
3.

Actual Results:  
Child window (enlarged photo) will incorrectly open UNDER the parent window.

Expected Results:  
Child window should open OVER the parent window.
Sounds like the parent raises itself due to the page scroll or something....

Comment 2

16 years ago
Could be. I've been working on bug 163372 and I'm beginning to wonder why we
raise windows when focus is changed. I think what happens also here is that when
the image is clicked, the new window is opened, but also the current one moves
to anchor causing some focus call or something. Now it depends only on the order
of these events if the result is correct or not. 

Comment 3

16 years ago
this is a dup of Bug 192454.
already fixed on trunk-nightly.
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs

Comment 5

15 years ago
1.3/WinNT has this problem, but 2003032808 and 2003051214/WinNT don't have.
Marking as dup of Bug 192454.

*** This bug has been marked as a duplicate of 192454 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.