folder tree loses focus when using keyboard to move up/down if QuickSearch (view) is active

RESOLVED DUPLICATE of bug 191813

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 191813
15 years ago
14 years ago

People

(Reporter: Lenard Gunda, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

The new Mozilla now allows to choose from a View: drop down in the active
folder, which is then used to view all folders (like a filter ... view all mail,
view non junk only, view important, etc). If anything other than "All" is
selected, whenever I step on the folder list tree with the cursor keys on the
keyboard, the folder view gets active. If "All" is selected, you can step
through folders simply, because the folder tree remains active after movement.
(Note: clicking on the folder tree on a different folder while not "All" is
selected also makes the focus go away into the folder view).

The lost focus actually goes into the "Subject or Sender contains:" edit field
in the folder view.

Reproducible: Always

Steps to Reproduce:
1. While any folder is active, select a View, like Not Junk
2. Activate the folder tree (left side of Mozilla Mail Window), click on the
currently open folder
3. Use up or down cursor key on keyboard to move

Actual Results:  
The new folder got selected (above or below), and the focus went away, into the
"Subject or Sender contains:" edit field in the folder view (right hand side).

Expected Results:  
The focus should have stayed in the folder tree, to be able to continue
selecting folders. Previous version worked like this. This version works like
this, if "All" is selected from the View dropdown on top of the folder view.

Comment 1

15 years ago
Duplicated with
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

Changing summary name to replace "filter" with "quicksearch," the correct name 
for that field.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: folder tree looses focus when using keyboard to move up/down if folder filter (view) is active → folder tree loses focus when using keyboard to move up/down if QuickSearch (view) is active

Comment 2

15 years ago
This also happens with mouse click on a folder as described in bug 189640.
Marking dup.

*** This bug has been marked as a duplicate of 189640 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
I have to wonder about this dupe -- I cannot reproduce the symptom in that bug, 
whereas I can with this one.

Comment 4

15 years ago
This symptom still exists, Mozilla 1.5 Final.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

14 years ago
Found an earlier report.  Note the cross-reference at that bug to another where 
a pending patch may address this problem.

*** This bug has been marked as a duplicate of 191813 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.