When I access any chat room on Delphi Forums, I get an error message, and the chat room does not open.

RESOLVED WONTFIX

Status

SeaMonkey
General
RESOLVED WONTFIX
15 years ago
13 years ago

People

(Reporter: JohnB, Assigned: asa)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.2.1) Gecko/20021130

When I try to access the chat room at
http://forums.delphiforums.com/n/chat/pchat/LaunchChatWindow.asp?webtag=bpso&roomname=%23BPSO&title=BPSO&new=y,
I see two modal dialog boxes that return the following error message: 

java.lang.ArrayIndexOutOfBoundsException

0 >= 0

After I dismiss the error messages, the chat applet does not load. When I access
this URL (or any other chat room at www.delphiforums.com, for that matter) using
Internet Explorer 5.06, the chat room loads correctly with no error message. The
chat room also loads correctly using Netscape 7.02 running under Windows 98, but
this is a Mac OS 9-specific issue. I don't have a Mac running OS X, so I can't
verify whether this error occurs under OS X.

Reproducible: Always

Steps to Reproduce:
1. Go to any forum at forums.delphiforums.com (e.g.,
http://forums.delphiforums.com/bully/chat).
2. In the lower-right frame of the window click on the name of the chat room
(the chat room hyperlinks do not display the URL on mouseover by design).
3. After the error messages are dismissed, all that appears in the window is the
colored background and an ad.

Actual Results:  
I saw the error dialog described above:

java.lang.ArrayIndexOutOfBoundsException

0 >= 0

The chat room window was blank, except for advertising and some controls.

Expected Results:  
The chat room applet should have loaded by stating the version of PChat running
in the leftmost frame. In the right most frame there should have been a list of
participants in the chat. Below the chat text listed should have been a text
entry box with an Enter button. A Whisper button should have appeared below the
list of participants.

I was using Mozilla's default theme.
(Reporter)

Comment 1

15 years ago
Created attachment 117548 [details]
A screenshot of a PChat chat room

This screenshot shows the PChat chat room as it is rendered using Internet
Explorer 5.06 for the Mac running under Mac OS 8.6.
So not Build Config
Assignee: seawood → asa
Component: Build Config → Browser-General
QA Contact: granrose → asa

Comment 3

15 years ago
Unfortuanly support for mac classic is dead -> WONTFIX.

(Even though this probably is a bug in Apples MRJ, and therefore really should
be invalid, IE uses its own java engine)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.