Ability to sort table rows in the browser

RESOLVED DUPLICATE of bug 104639

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 104639
16 years ago
16 years ago

People

(Reporter: pabs3, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.08 [en] (Win98; I ;Nav)
Build Identifier: 

Where HTML tables are used as they should be, not for layout, a great thing 
would be the ability for the user to be able to right-click on a <th> and sort 
all the rows by that column. Tertiary sorting would probably be enough, but 
specifying arbitrary sortings would be good.

Reproducible: Always

Steps to Reproduce:
1.Goto http://docbook.org/wiki/moin.cgi/DocBookAuthoringTools
2.Wish you could sort by the free column, without editing the page
3.Think about reporting a bug

Actual Results:  
I reported this bug

Expected Results:  
Been an operating system

Comment 1

16 years ago
->Layout
Assignee: asa → table
Component: Browser-General → Layout: Tables
QA Contact: asa → madhur
This could be done, actually, with a simple add-on... not sure that this needs
to be part of the default layout engine, however.  CCing jesse, since I bet he
has a bookmarklet for this or wants to write one.  ;)

Comment 3

16 years ago
Looks like a duplicate of bug 104639.

Oh, and Jesse does already have a bookmarklet:
http://www.squarefree.com/bookmarklets/pagedata.html#sort_table

*** This bug has been marked as a duplicate of 104639 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
That bookmarklet is cool, but can't sort according to multiple columns. Also I 
had thought of implementing it as an entry on a context menu + some tooltips 
for sort order feedback, instead of modifying the table. Either way is OK I 
guess, but I don't think adding another row is the right way to do it, rather 
the up/down things should be part of the header row, either before or after the 
cell content, maybe depending on the horz alignment.
You need to log in before you can comment on or make changes to this bug.