"plugin.expose_full_path" pref doesn't work

RESOLVED FIXED

Status

()

Core
Plug-ins
--
major
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Pete Zha, Assigned: Peter Lubczynski)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Reproduce:
1) set "plugin.expose_full_path" to true in all.js(<moz-dir>/defaults/pref/all.js)
2) start mozilla and the open menu:Help->About Plugins

Expect result:
This page will show full path of each plugin

Actually result:
This page only show the file name of each plugin
(Reporter)

Comment 1

15 years ago
See here:
http://lxr.mozilla.org/seamonkey/source/modules/plugin/base/src/nsPluginHostImpl.cpp#4227

mPluginTag.mFilename is just the filename, not include the path, so this happens.
(Assignee)

Comment 2

15 years ago
Sounds like a regression from the mini-mo landing:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/modules/plugin/base/src&command=DIFF_FRAMESET&file=nsPluginsDirUnix.cpp&rev2=1.29&rev1=1.28

Perhaps nsPluginDirUnix.cpp should use |GetNativePath| instead of
|GetNativeLeafName| for info.fFileName.
(Reporter)

Comment 3

15 years ago
Today's build works for me. This bug has been fixed by bug 197855.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.