window.open with modal attribute doesn't work anymore

RESOLVED DUPLICATE of bug 197351

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 197351
15 years ago
13 years ago

People

(Reporter: Alessandro Fiorino, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3) Gecko/20030312

With Mozilla 1.2.1, a window opened with
window.open(url,name,'modal=1')
used to be an application modal window, blocking all events (both keyboard and
mouse) on the opening window until the opened window is closed.
With Mozilla 1.3 (also beta versions) it doesn't work anymore: the new window
stays on top of the opener, but the user can still interact with the window below.

Reproducible: Always

Steps to Reproduce:
1. Open a simple page like this
<html>
<body>
Try to click <a href="javascript:window.alert('Test')">this</a>
<script>
window.open('http://www.mozilla.org','_blank','modal=1');
</script>
</body>
</html>
2. Try to click on the link without closing the new window
Actual Results:  
I can click on the link in the background window and an alert  popup is opened

Expected Results:  
Block the interaction with the background window until I close the new window

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 197351 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.