If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

dropdown list boxes are causing crash

RESOLVED INVALID

Status

()

Core
Layout: Form Controls
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Judson Valeski, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows XP
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Over the past 5 days, using trunk mozilla builds on winxp, I've crashed several
times when selecting some drop down listboxes. stacktraces all boil down to
basically the same thing.

Some of the sites I've experienced this on are:
ticketmaster.com
symantec.com
apc.com

talkback reports:
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18202238
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18202199
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18137284
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18137266
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18137243
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18106222
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18103001
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18102977
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18102950
http://climate.netscape.com/reports/SingleIncidentInfo.cfm?dynamicBBID=18102929

testcase:
1. load http://www.symantec.com/techsupp/consumer.html?asa=re
2. click on the "select a product" list box and crash.

I'm not able to repro this using moz trunk winxp build 2003031408 on my work
machine; my home machine is 100% repro on this though.
(Reporter)

Comment 1

15 years ago
Created attachment 117605 [details]
sample stack trace from talkback reports
(Reporter)

Updated

15 years ago
The top three frames of that stack are garbage (functions that don't call each
other, especially given those line numbers).  It seems like what talkback thinks
the build is and what it really is disagree.
Summary: dropdown list boxes are causing crash (nsCSSDeclaration::SetValueImportant) → dropdown list boxes are causing crash

Comment 3

15 years ago
WFM.  2003031804 / XP.
(Reporter)

Comment 4

15 years ago
cc'ing Shiva; maybe we have a talkback problem? all of those talkback reports I
point to show the same thing.
It's also possible that the cause of both the crash and the talkback problem is
that you're picking up libraries from an old install that you installed over.
(Reporter)

Comment 6

15 years ago
good call dbaron. i stripped myself clean, re-installed and i can't repro this
anymore; snuffing bug.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
I wouldn't necessarily call it invalid, but hopefully it will be fixed by the
patch on bug 197237.

Comment 8

15 years ago
Jud - I went through all the pasted incidents and found these three signatures.

nsCSSDeclaration::SetValueImportant 5c758be6
XPCWrappedNative::CallMethod 4700db20
js_AllocStack edadc5d4


You need to log in before you can comment on or make changes to this bug.