Closed Bug 198063 Opened 21 years ago Closed 21 years ago

position:relative divs come above floats in z-order

Categories

(Core :: Web Painting, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 191830

People

(Reporter: bzbarsky, Assigned: roc)

Details

Attachments

(1 file)

A float should be above content that comes after it for the whole float thing to
be useful (since floats will overlap flow boxes after them).  But if a box is
position:relative, this breaks.
Attached file testcase
Summary: position:relative divs come above floats in x-order → position:relative divs come above floats in z-order

*** This bug has been marked as a duplicate of 191830 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Actually, per the latest CSS2.1 spec this bug is simply invalid.
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.