div with overflow:auto inside table does not render correctly

RESOLVED DUPLICATE of bug 192941

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 192941
15 years ago
15 years ago

People

(Reporter: Jesse Kasky, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

A div with overflow:auto,width:100%,height:100% placed inside a table will not
render correctly when the contents of the div is larger than the containing
table.  If the contents of the div is larger than the containing table then
overflow scrollbars should be added to the div.

Reproducible: Always

Steps to Reproduce:
1. Open Browser.
2. Resize Browser to about 400 x 400.
3. Open the attached example code.

Actual Results:  
The table size expands beyond the contents of the browsers client area causing
the browsers main vertical scroll bar to be enabled.

Expected Results:  
The table size should remain fixed at 100% of the client area and overflow
scrollbars (horizontal & vertical) should be added to the div.

In version 1.2.1 the results are slightly different.  Initially the contents of
the div is not visible at all.  But resizing the window causes the client area
to refresh and then everything is rendered correctly.  In version 1.3 the
contents of the div is visible initially but the layout is not rendered correctly.
(Reporter)

Comment 1

15 years ago
Created attachment 117652 [details]
Example to reproduce

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 192941 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.