Closed Bug 198197 Opened 18 years ago Closed 18 years ago

Image title tooltip not shown correctly

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect)

x86
Linux
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 45375

People

(Reporter: ferry, Assigned: jdunn)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

Any image title that has line-feeds or carriage returns in them is not shown
correctly. The line feeds and carriage return characters show up in the image
tooltip as non printable characters instead of line feeds and carriage returns.

Reproducible: Always

Steps to Reproduce:
1.make a page with an image tag something like this:

<img title="Line 1
Line2" src="some picture">

2. hover over the picture in the browser

Actual Results:  
see details

Expected Results:  
see details
still present in mozilla 1.3 release version
Please search before you file a bug : see bug 45375, bug 47078 and bug 67127.

BTW: it's not really a bug (see bug 47078) becuase a linefeed inside HTML should
be ignored (it's just whitespace), although a lot of people expect to have
multiline tooltips, like IE.



*** This bug has been marked as a duplicate of 45375 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 67127 ***

*** This bug has been marked as a duplicate of 67127 ***
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.