1.3 final build will not start on Solaris 9

RESOLVED INVALID

Status

--
blocker
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: Matt.Behrens, Assigned: asa)

Tracking

Trunk
Sun
SunOS

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2.1) Gecko/20021217
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.3/mozilla-sparc-sun-solaris2.7-1.3.tar.gz

Neither the 1.3 beta build nor the 1.3 final builds will start on Solaris 9.

I'm not using gcc-compiled GTK (well, I *think* I'm not, at least) because I'm
simply using those which come with Solaris 9.

I will attach truss output.



Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
Created attachment 117712 [details]
Output of './run-mozilla.sh -g -d truss ./mozilla-bin'
(Reporter)

Comment 2

16 years ago
Ah, I neglected to mention that the 1.2.1 builds worked fine for me.

Comment 3

16 years ago
Reporter:
Does Mozilla work on your box when you use the GDK/GTK+ libs from
http://puck.informatik.med.uni-giessen.de/people/gisburn/work/mozilla/moz_gdk_gtk_gmodule_libs_solaris2.7_2000-07-17.tar.gz
(which are compiled with Sun Workshop) ?

Comment 4

16 years ago
Reporter, would you please try this build?
http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.3/mozilla-sparc-sun-solaris2.8-1.3.tar.gz
This build is built on Solaris 8 and should work on Solaris 9.
(Reporter)

Comment 5

16 years ago
I tried the 2.8 build first.  Same result.  truss looked similar but I didn't
actually compare.  There could be a key difference; let me know if you need it.

Roland's GTK got me a little further, but the entire app hung after the password
dialog popped.
(Reporter)

Comment 6

16 years ago
Of course, I shouldn't have changed two variables at once. :-)  If I use
Roland's libs with the _2.7_ build, all appears well.  I'm making this update
from just that setup, in fact.

Comment 7

16 years ago
You may look at the readme file in
http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.3/mozilla-sparc-sun-solaris2.8-1.3.tar.gz
And you can download the forte build gtk library from netscape7 installer.
Before run mozilla, you need to set LD_LIBRARY_PATH=<gtk-lib-path>. For example:
export LD_LIBRARY_PATH=/usr/sfw/lib
(Reporter)

Comment 8

16 years ago
You know what?  I'm a moron.  I didn't have *any* GTK libs on my
LD_LIBRARY_PATH.  I guess that would account for the failure, wouldn't it?

The reason 1.2.1 worked is that is was compiled as follows:

ac_add_options --with-glib-prefix=/usr/sfw
ac_add_options --with-gtk-prefix=/usr/sfw

In addition, the 'mozilla' script has this:

LD_LIBRARY_PATH=/usr/sfw/lib:$LD_LIBRARY_PATH

Anyway, it might be prudent to add such a thing to the 1.3 builds.  Sorry to
waste everyone's time.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.