Add a keyboard shortcut for Text Zoom 100% (Original Size)

VERIFIED DUPLICATE of bug 69565

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 69565
16 years ago
16 years ago

People

(Reporter: bugzillamozilla, Assigned: aaronlev)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030318
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030318

After zooming in and out, the user is required to use the menu in order to
restore the page to its original Text Zoom.

Providing a keyboard shortcut for this action will make it a lot quicker than
using the mouse.

Currently, it can be achieved with mnemonic-enabled platforms using
Alt->V->Z->Z, but this is not as convenient as a real keyboard shortcut and it
isn't available on Macs.

Judging by available mappings (see Mozilla Keyboard Assignment Map), the best
candidates for this shortcut are (IMHO):

Accel + 0 )
Accel + Numeric Keypad "*"
Accel + Numeric Keypad "/"

On Opera, the shortcuts for "Restore zoom to 100%" are are 6 and Numeric Keypad
"*". I'm not sure if this functionality exists on other browsers.

Prog.

Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
I believe Accel + 0 already does this. At least it seems to on 2003031605 / linux
(Reporter)

Comment 2

16 years ago
Now that I try this, it also works on Win2k (20030318) and Mac OS X (20030122).
Why isn't it documented?

I believe that we should do the following:

1. Add a Numerical Keypad shortcut to all platforms. Currently, the Mac version
implements Accel + Numeric Keypad 0, the Windows version doesn't.
2. Add a description in the menu.
3. Correct the online documentation (such as the above link).

Prog.
(Reporter)

Comment 3

16 years ago
Accel + Numeric Keypad 0 also works fine with OS/2 (20030313).

Comment 4

16 years ago
It seems there is agreement that this works in Win2000, Linux, Mac and OS/2.
I can't see there is a bug here at all? Resolving as dup of bug 69565, fixed two
years ago.

*** This bug has been marked as a duplicate of 69565 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Why isn't the accel-0 shortcut shown in the view->text zoom->100% menu? Maybe
this should be reopened and summary changed to make existing shortcut visible in
the menu? Without this bug, I wouldn't have known the shortcut existed.
(Reporter)

Comment 6

16 years ago
I agree that this was originally a dupe of bug 69565, but the fact remains that
this shortcut isn't documented anywhere (which is why I opened this bug).

This is what's availble in Mozilla's help file:
=============================================================================
Page Viewing Shortcuts
Command 	Windows 	Macintosh 	Linux
Zoom Text Smaller 	
Ctrl+- (minus sign)
Cmd+- (minus sign)
Ctrl+- (minus sign)

Zoom Text Larger
Ctrl+= (plus sign)
Cmd+= (plus sign)
Ctrl+= (plus sign)
=============================================================================


The Mozilla Keyboard Assignment Map (link above) doesn't specify Accel+0:
=============================================================================
 Browser content  	Composer  	Mail folder/thread panes  	Widget Behavior
0 ) 	  	  	  	 
  + shift 	  	  	  	 
  + accel 	  	  	  	 
  + accel+shift 	  	  	  	 
=============================================================================

Finally, the menu entry should ve "100% ctrl+0" instead of "100% (Original Size)"

I believe that this bug should be re-opened as a documentation bug, with a
different title (perhaps "Document Accel+0 for zoom to 100%").

As for why it doesn't work on my Win2k nightly of v1.4a, I'll have to verify
this with v1.3-final.
Prog.
(Reporter)

Comment 7

16 years ago
OK, I've tested this on Win2k with three different 1.3x builds (20030108,
20030224 and the final 20030312) - they all fail to restore the zoom with
Accel+NumPad 0.

Can anyone else verify this? Should I open a new bug?

Prog.

Comment 8

16 years ago
yes, open a new bug for that. There used to be problems on Windows with zoom on
the numeric keypad. Fixed in bug 70141. The reset-shortcut must have been forgotten.
(Reporter)

Comment 9

16 years ago
Ok, I'll open a new bug for that.

Now- what about the lack of documentation for this shortcut? I definitely needs
to be corrected, don't you agree?

Prog.

Comment 10

16 years ago
I just tried W2K & 1.2.1. Ctrl-lower ) works, but Ctrl-numpad ) does not.
(Reporter)

Comment 11

16 years ago
I just opened Bug 198233 about this ("Ctrl+NumPad 0 does not restore Text Zoom
to 100%")
However, I still think that our main problem now is in the lack of documentation.

Prog.
(Reporter)

Comment 12

16 years ago
I had filed two new bugs for the issues that were mentioned here:

Bug 198369 -> Document Accel+0 (Reset Text Zoom to 100%)
Bug 198375 -> Add "Accel+0" to menu entry for Text Zoom 100%

Thank you R.K.Aa for the advise.

Prog.

Comment 13

16 years ago
.
Status: RESOLVED → VERIFIED
Summary: RFE: Add a keyboard shortcut for Text Zoom 100% (Original Size) → Add a keyboard shortcut for Text Zoom 100% (Original Size)
You need to log in before you can comment on or make changes to this bug.