All users were logged out of Bugzilla on October 13th, 2018

won't save a message to "Sent" folder (no data sent to imap server)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: jcg1, Assigned: Bienvenu)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

For hours, this would work fine...

compose a messase
message would send
message would write to sent mail folder

Until finally it breaks....

compose a messase
message would send
message would *not* write to sent mail folder

sent message to self (as a test)
message would send
message would *not* write to sent mail folder

"get messages" would *not* retrieve message just sent

turned on tcpdump on port 993 (I use imaps usually, but I get the same behavior
using imap)

sent message to self (as a test)
message would send
message would *not* write to sent mail folder

tcpdump output showed no communication at all

checked processes... Mozilla not comsuming all memory or cpu,
just usual small amounts of each

stopped mozilla
restarted mozilla

opened mail

messages sent to self are now in inbox
sent message to self
message would send
message written to sent mail folder

The delay between working and breaking is hard to figure.  I left mozilla open
over night.  Got in and sent a message to myself.  Worked fine.  Very next mail
message sent an hour later and it was broken.


Reproducible: Always

Steps to Reproduce:
1.open mozilla mail and use normally... eventually (this happens every day,
sometimes several times per day) 
2.compose a messase
3.message would send
4.message would *not* write to sent mail folder
Actual Results:  
compose window stays open.
dialogue box status message reports mail being sent
message in box changes to say message being written to "Sent" folder
if you wait, eventually  a dialog box says message could not be written to sent
do you want to return to composition window.

Expected Results:  
send mail
write mail to sent folder on imap server

I have been using mozilla since version 0.98 as my primary mail tool and
browsing tool.  I have not altered my typical behavior.  I leave my mail and
browser open all the time and have never had this problem before.
(Reporter)

Comment 1

16 years ago
I've left a packet sniffer running to catch the problem in action.  It turns out
the mail server sent me two TCP resets.  This freaks mozilla out.  I realize the
connection ends with a RST, but why doesn't mozilla recover?

The mail is sent (SMTP) it no problem.
The mail is often even saved to the "SENT" mail folder (all problems seen today
have had this behavior).

The dialog box saying the mail was being "saved to the sent mail folder" simply
lives on and mozilla mail is dead from that point on.  I cant get new mail.  I
can send new mail, but those messages will not write to my sent folder.

Why didn't the application accept the TCP reset, let go of the connection and
then establish a new connection?

I can confirm that I am receiving the TCP RST from the imap server (I'm now
logging them with iptables).

Comment 2

16 years ago
I've been having this same problem on Windows:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Although sometimes the mail *will* get sent.
(Assignee)

Comment 3

15 years ago
could you please try a 1.5 b build? We've added code to detect imap connections
that have been reset.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
Dropping off, I use Thunderbird these days and haven't had this problem.
(Assignee)

Comment 5

15 years ago
this thunderbird code is exactly the same as the mozilla code. Marking wfm
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.