In editorPrefsOverlay.xul, the term "Toolbars" appearing in Preferences is hardcoded and cannot be localised

VERIFIED FIXED

Status

SeaMonkey
Composer
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: aleksr_si, Assigned: neil@parkwaycc.co.uk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; sl-SI; rv:1.4a) Gecko/20030319
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; sl-SI; rv:1.4a) Gecko/20030319

In the file editorPrefsOverlay.xul, which is located in
comm.jar/content/editor/, the term "Toolbars" is not a variable, and thus cannot
be localised per normal procedures.

In the treecell tag that links to pref-toolbars.xul, the label should be
something like &toolbars.label;, just as pref-editing.xul has a label of
&editing.label;. Instead, it simply states "Toolbars".

The issue is apparently quite easy to fix -- it probably just sneaked past the
author, since this is a new feature in 1.4. Either way, it IS important to
ensure polish in localised builds, and hence I hope it is mended.

Reproducible: Always

Steps to Reproduce:
Editor bug.  Ccing neil, since he checked this in...
Assignee: rchen → composer
Severity: minor → normal
Status: UNCONFIRMED → NEW
Component: Localization → Editor: Composer
Ever confirmed: true
OS: Linux → All
QA Contact: ylong → petersen
Hardware: PC → All
(Assignee)

Comment 2

15 years ago
And after I went to all the trouble of making the panel localizable, too :-[
Assignee: composer → neil
(Assignee)

Comment 3

15 years ago
Created attachment 117839 [details] [diff] [review]
Proposed patch
(Assignee)

Updated

15 years ago
Attachment #117839 - Flags: superreview?(alecf)
Attachment #117839 - Flags: review?(brade)

Updated

15 years ago
Attachment #117839 - Flags: review?(brade) → review+

Comment 4

15 years ago
Comment on attachment 117839 [details] [diff] [review]
Proposed patch

sr=alecf
Attachment #117839 - Flags: superreview?(alecf) → superreview+
(Assignee)

Comment 5

15 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 6

15 years ago
Verified in the 2003-04-11-03 Macho build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.