onclick not seen as a "link" - text cursor instead of finger, java function not called

RESOLVED INVALID

Status

()

Core
Event Handling
RESOLVED INVALID
15 years ago
14 years ago

People

(Reporter: William Hofmeyr, Assigned: saari (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

several constructs of the form: 
<a onclick="toggle(Cleanup)" onmouseover="this.style.color='red'"
onmouseout="this.style.color='black'"><h3>CleanMgr <img src="images/rarrow.gif"
width="14" height="14"></h3></a>
<span ID=Cleanup Style=Display:None> 
<p>Still hacking this one.
<p><a onclick="toggle(Cleanup)" onmouseover="this.style.color='red'"
onmouseout="this.style.color='black'">Collapse section <img
src="images/uarrow.gif" width="14" height="14"></a>
</span>

are used in this page. 
The tag is not seen as a clickable region.
The cursor does not change to the one used over links.
The function is not invoked.


Reproducible: Always

Steps to Reproduce:
1. go to URl
2. try moune over one of the subjects
3.  

Actual Results:  
cursor changes to text cursor instead of link-following pointing hand.
clicking does not invoke function.

Expected Results:  
Cursor should change to hand
Function should be invoked
> The tag is not seen as a clickable region.

It's not seen that way in any browser I'm aware of... We mark actual <a href="">
tags as links; those are not links.

> The cursor does not change to the one used over links.

Same

> The function is not invoked.

It is, but it uses IE-only code that gives a JS error in Mozilla.

Comment 2

15 years ago
>It's not seen that way in any browser I'm aware of... We mark actual <a href="">
tags as links; those are not links.

Does the hand thing in IE 6.

Comment 3

15 years ago
It does show a hand due to the css:
A		{font-size: 85%;color: black;font-weight:bold; text-decoration: none;cursor:
hand}
A.header	{font-size:100%;color: white;font-weight:bold; text-decoration:
none;;cursor: hand}
A:hover		{font-size: 85%;color: red;font-weight:bold; text-decoration:
none;;cursor: hand}

and again, cursor:hand is an IE-only property, the correct way is cursor:pointer;

so none of the problems are due to Mozilla but to bad coding of the page (it's
incredible using onmouseover and onmouseout instead of :hover just to change the
color). If the author cares just a little he can update easily the markup to
work in any modern browser.
Resolving as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.