File Bookmark dialog does not have a resize grippy widget under Windows and OS/2

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: Prognathous, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2.1) Gecko/20021201
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2.1) Gecko/20021201

The problem does not happen under OS X 10.2.4 and Linux RH 8.0 (all tested with
1.3-final), but it is easy to reproduce under Windows (I verified it with Win2k).

Since by default this dialog is too small (Bug 146859), it is important to make
it clear that it is resizable.

Reproducible: Always

Steps to Reproduce:
Press Ctrl+Shift+D to open the File Bookmark dialog.
Actual Results:  
The dialog has no visible resize widget ("grippy")

Expected Results:  
The resize widget should be visible.
(Reporter)

Updated

15 years ago
Summary: Under Windows and OS/2, File Bookmark dialog does not have a visible resize widget → File Bookmark dialog does not have a visible resize widget under Windows and OS/2

Comment 1

15 years ago
that would be a generic toolkit bug, it's unlikely we'd fix it for just this
dialog. (hey bz, you're now an xptk peer)
OS: other → Windows 2000
This is XPFE, not xptk, no?
(Reporter)

Comment 3

15 years ago
The resize widget is invisible on other *resizable* windows and dialogs:

* Popup Exceptions dialog
* Customize Character coding dialog
* Form Manager
* Cookie Manager
* Image Mmanager
* Password Manager
* Javascript Console
* DOM Inspector
* Source Viewer

I guess a more apt title for this bug would be "Resize widget on many dialogs
and windows is invisible"...

Prog.

Updated

15 years ago
Whiteboard: DUPEME

Comment 4

15 years ago
see bug 27795

this is a question of whether a window w/ no status bar should have a
resizing grippy
Summary: File Bookmark dialog does not have a visible resize widget under Windows and OS/2 → File Bookmark dialog does not have a resize grippy widget under Windows and OS/2
(Reporter)

Comment 5

15 years ago
> see bug 27795

Well, I couldn't find that bug, otherwise I would have definitely added this as
a comment there first, instead of opening a new bug.

> this is a question of whether a window w/ no status bar should have a resizing
grippy

That’s exactly the point. Most windows do show this grippy, but resizable
dialogs don't. And since users don't get this important feedback, they never
discover that a resize is possible (a big issue with the bookmark dialogs)

Prog.

Comment 6

15 years ago
Are you saying that you can re-size the File Bookmark dialog on Windows? I
cannot appear to do this with a 1.4a release build!!! 

I can with other dialogs (which have no grippys) such as Tools->Popup
Manager->Manage Popups. 

Comment 7

15 years ago
Oops... sorry for the spam. I just found that the problem with not being able to
re-size the File Bookmark dialog is covered by Bug 199524

Comment 8

15 years ago
The File Bookmark was working on OS X as of a build or two ago, but now is
displaying the same stange behavior as the other OS builds. This is with build
2003040910. It also used to have a resize corner, which has now also disappeared.

Updated

15 years ago
QA Contact: kasumi → petersen

Comment 9

15 years ago
Working again on OS X thanks to the fixes in Bug 199520 and Bug 199524.

Comment 10

15 years ago
Verified works for me in the 2003-05-07-03 Macho build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.