Remove "delete" and "undo" from context menu presented when selecting un-editable text

RESOLVED WORKSFORME

Status

()

--
trivial
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: sexyeuroboy, Assigned: hyatt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030221 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030221 Phoenix/0.5

There are pointless options in the context menu accessed when a portion of
non-editable text (displayed html) is right-clicked. "Delete" and "undo" are
always greyed out when non-editable text is selected (even if some undo-able
action has been carried out in an editable text area previously).

Reproducible: Always

Steps to Reproduce:
1. find a textbox in a page, type something, select what you've written and
"delete" from context menu.
2. select some non-editable text on the same page (for instance some html text).
3. right-click the selected non-editable text.

Actual Results:  
the context menu contains "undo" and "delete", although both are greyed out.

Expected Results:  
presented a context menu which didn't contain the useless options.

Tested on Phoenix, but I'd be very surprised if it doesn't apply to Mozilla too.
(Reporter)

Updated

16 years ago
Summary: Remove "delete" and "undo" from context menu upon presented when selecting un-editable text → Remove "delete" and "undo" from context menu presented when selecting un-editable text
This is already filed.
Whiteboard: DUPEME

Comment 2

16 years ago
->menus
Assignee: asa → hyatt
Component: Browser-General → XP Toolkit/Widgets: Menus
QA Contact: asa → shrir
I think this is allready fixed.




I tested with :


- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030410 
Phoenix/0.5+




- Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401




Reporter: can you retry this with a more current build to see if it is fixed for 
you too.










Comment 4

15 years ago
.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.