Last Comment Bug 198419 - autocomplete="off" should additionally affect Form Manager
: autocomplete="off" should additionally affect Form Manager
Status: RESOLVED WORKSFORME
: dataloss
Product: Toolkit
Classification: Components
Component: Form Manager (show other bugs)
: Trunk
: x86 Windows XP
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Matthew N. [:MattN] (PM me if requests are blocking you)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-20 08:37 PST by Arun Ranganathan
Modified: 2010-03-12 12:02 PST (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Arun Ranganathan 2003-03-20 08:37:43 PST
Currently, autocomplete="off" turns of Password Manager.  This is desired
behavior.  But autocomplete="off" doesn't affect Form Manager, and it does work
this way in IE.

This creates an odd distinction between which forms are passwords and which
aren't.  Since we already implement a non-standard enhancement to the HTML of
the form (and are copying IE) let's go the whole way and allow the
autocomplete="off" behavior to affect form manager as well, and thus stop the
autocompletion of forms.

Certain banking institutions have requested this.
Comment 1 Thomas Swan 2003-06-04 11:29:39 PDT
Any timeline for this getting fixed?
Comment 2 Ian Thomas ('thelem') 2004-02-03 13:39:21 PST
I have a website with 2 forms, one has
Name & Email Address
the other has
Website Name & MySQL Server Address

Because they both contain the keywords Name and Address, they bring up the 'Do
you want to save the values' dialog box.

All the form fields are prefilled from my database. If someone clicks yes to
save the values they submit, then later on the values in the database change
(perhaps they update them, possibly from a different computer), then they return
to the form using mozilla then the old values will be put into the form,
overwriting the values in the database.

adding dataloss keyword
Comment 3 Walter K. 2004-02-16 04:42:34 PST
See Netscape recommendation for workaround:
http://devedge.netscape.com/viewsource/2003/form-autocompletion/
Comment 4 moshe weitzman 2005-08-31 08:25:09 PDT
still happenning on latest firefox. is a shame ...
Comment 5 tech 2005-09-20 06:11:24 PDT
(In reply to comment #4)
> still happenning on latest firefox. is a shame ...

(In reply to comment #3)
> See Netscape recommendation for workaround:
> http://devedge.netscape.com/viewsource/2003/form-autocompletion/

There's another workaround here
http://developer.mozilla.org/en/docs/How_to_Turn_Off_Form_Autocompletion#Original_Document_Information
... but it doesn't work
Comment 6 Bryce Mozilla Nesbitt 2005-12-15 15:11:47 PST
It would be great if I could get predictable results, as a webmaster, by using some standard names, like the ECOM names:

<form name="form1" id="form1" method="post" action="http://www.example.com/form.cgi">
 <input type="text" name="Ecom_ShipTo_Postal_Name_First" /><br/>
 <input type="text" name="Ecom_ShipTo_Postal_Street_Line1" /><br/>
 <input type="text" name="Ecom_Payment_Card_Number" autocomplete="off" /><br/>
 <input type="Submit" name="Submit" value="Submit" />
</form>
Comment 7 Gervase Markham [:gerv] 2006-10-06 08:40:21 PDT
*** Bug 350785 has been marked as a duplicate of this bug. ***
Comment 8 Gervase Markham [:gerv] 2006-10-06 08:40:40 PDT
*** Bug 351700 has been marked as a duplicate of this bug. ***
Comment 9 Aaron Greenspan 2007-01-25 17:57:18 PST
This is still happening for me. I'm using SeaMonkey 1.1. I tried using the SPAN tag to break up the word "Address" twice on my form, but I can't change the field names so the workaround I read about isn't much of a workaround.

Any help would be greatly appreciated!
Comment 10 Paul 2007-03-14 08:42:05 PDT
I am also finding issues with this problem.

I developed a website where when I edit user details, I autofill in the fields based on that user's details. Then Mozilla Firefox overwrites this with my details in these fields. Firefox should check for fields that already have data in it, and not overwrite it if AutoComplete=true by default.
Comment 11 Ralf Hauser 2007-04-09 09:36:47 PDT
too bad, this issue is still pending with Firefox 2.0.0.3

Also, I faintly recall to having been able to define site urls as exceptions to the form managers. Right now, I only find the possibility to turn off the form manager altogether by unchecking "Remember what I enter in forms and the search bar" (Tools-Options-Privacy-History)
Comment 12 Justin Dolske [:Dolske] 2008-05-26 16:53:35 PDT
WFM in the current satchel/pwmgr. Wallet is depreciated.
Comment 13 Daira Hopwood 2010-03-12 12:02:27 PST
If what https://developer.mozilla.org/En/How_to_Turn_Off_Form_Autocompletion says about this bug is incorrect for current Firefox, then that page should be fixed.

Note You need to log in before you can comment on or make changes to this bug.